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Configuration Guide for WorkZone Find
PURPOSE

The purpose of this guide is to explain the WorkZone Find configuration process. It also provides
an insight into the key configuration and administration components: WorkZone Find Index
Manager and WorkZone Find Connector Manager.
TARGET AUDIENCE

The guide is primarily targeted at the administrators and super users who know the WorkZone
Find functionalities and have technical skills to configure WorkZone Find components.
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Configuring WorkZone Find Server
This section will guide you through the configuration process of the WorkZone FindServer.
In this section you will learn about:
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Configuring Initial Settings for WorkZone Find Server
On the last step of the Installation wizard you will be offered to configure initial WorkZone Find
settings through a Configuration wizard.
If you want to start configuring the settings right after the installation, leave the Start
configuration check box selected. If you want to do this later, clear the check box.
Note: ScanJour recommends you to perform the initial configuration immediately after the
installation.
When you want to change the settings, click Start > WorkZone Find Configuration Wizard to
start the wizard.
How to perform configuration
1. On the Welcome to the WorkZone Find initial configuration page click Next.
2. On the Set credentials page, specify the following credentials for the WorkZone
Find administrator user:
l

User name

l

Domain

l

Password

The services (including COM+) and application pools will run under the specified credentials.
If the specified account does not have the required local rights, you will be offered
to add the Log on as a service and the Log on as a batch job permissions to the
specified account. To add the permissions, click Yes in the confirmation dialog box.
In other case, specify different credentials.
Click Next.
Note: This step is available only if you performed clean installation (the Index service has never
been started).
3. On the Specify locations for WorkZone Find server features page, specify the
following locations:
l

Default WorkZone Find location – specify common location for WorkZone
Find index, WorkZone Find log, and WorkZone Find backup files. You can
also specify different locations for each file in the fields below.

l

Index location

l

Log location. In this location only the index and connector logs will be
stored. All the other logs are stored in the default location.

l

Backup location. By default, the Backup location is not specified. You can
set it later.

If you want to change the location, click Browse, and navigate to the required
location.
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4. Click Next. The page containing the list of components and services to be
updated is displayed. The components which are disabled in the list will not be
updated.
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5. Click Run. The Configuration wizard completes the following tasks:
1. Assigns appropriate locations to the components.
2. Assigns credentials to the corresponding services.
3. Starts the required services.
4. Scans Active Directory and adds AD users and groups to WorkZone
Find.
When the configuration tasks are completed, the configuration summary is
displayed. Click Close.
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Configuring Services on WorkZone Find Server
After you have run the Configuration wizard, ensure that identities of the following WorkZone
Find services are configured as in the table below and all set to automatic (delayed) start.
Service

Identity

Required

WorkZone Find Active

WorkZone Fin-

Yes

Directory Connector

dAdmin*

WorkZone Find Auto-

Local System

Yes

WorkZone Find Index

WorkZone Fin-

Yes

Service

dAdmin*

WorkZone Find Model

WorkZone Fin-

service

dAdmin*

WorkZone Find NTFS

WorkZone Fin-

Connector

dAdmin*

WorkZone Find ODBC

Local System

Only if you need to extract metadata from
backend systems. The service has to run
as a specific domain user only if SQL
Server accepts only NT authentication (no
DB authentication).

Local System

Only for ScanJour ECM installations.

Local System

Assign the credentials for WorkZone Find

Term Service

Connector

WorkZone Find Scan-

Yes
Yes

Jour Connector
WorkZone Find SharePoint Connector

SharePoint connector manually. Refer to
Prerequisites in the Installation Guide to
check the rights.

WorkZone FindAdmin* – this name is used as an example of the user account with the
administrative privileges.
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Configuring Index Settings
To configure the index settings, perform the following steps:
1. Open WorkZone Find Index Manager.
2. Click File > Index Settings.
3. Configure IndexSettingsC and Lucence settings.
4. Restart the WorkZone Find Index service.
How to configure IndexSettingsC
Configure IndexSettingsC setting as in the table below:
IndexSettingsC

Default

Recommended

Comments

Auto Tagging

AutoTaggingInterval

0

1 (if auto tag-

How often the auto tagging worker is running (in hours).

ging is used)
AutoTagManuallyTagged

False

If set to True, then manually tagged information items will
also be auto tagged. The manual tags will be removed when
the auto tagging procedure is performed for the second time.
Therefore, if manual tagging is used, you must set this option
to False.

IgnoreTermAutoTagFlag

False

Controls whether the Term AutoTag flags are respected by
the auto tagging. If set to True, all terms will be used for auto
tagging including the terms marked not to be used for auto
tagging.

Data Store – IO
DataFileGrowthSize

100

The size in WorkZone Find Model Builder defining the data
chunks sizes which are added to the index store when the
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Default

Recommended

Comments

Auto Tagging

index store is extended.
IncomingSectionSize

800

800

The size in WorkZone Find Model Builder defining the size of
index store transaction. Normally the largest transactions on
an index are initiated by the connectors scanning the repositories. (The setting is also used for the auto tagging temporary store). When you get errors of the type “Trying to
store too many pages in a single chunk” in the index error
file, you should increase this value.

IOWriteThrough

True

If set to False, the data will not be written through to the hard
drives spinning media. Set it to False only if the hard drive
controller has battery backup.

PageSize

8192

Size of the pages in the index (in bytes). ScanJour recommends you to set the value for this property less than
32767 B.

PersistChunckSize

16

Data size (in MB) to write to the incoming section of the data
file before flushing (note, that this will be kept in memory). If
you set greater number, the performance will increase.

Data Store – Memory
PageCacheSize

249

Data Store – Page Cache Priorities
BlockStoreDataPagePriority

100

BlockStoreFreeTextPagePriority 200
BlockStoreIndexPagePriority

50

TagInvListDataPagePriority

100

TagInvListIndexPagePriority

50
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Default

Recommended

Comments

Auto Tagging

Distributed
RemotingAddress

tcps://(server):9988/index

The remoting address is used to access a remote index
instead of a local index. If the index is local, the server name
will be the name of the local host. If the index is not local, the
server name should be changed to the name of the remote
server running the index.

Files and Folders
DataFileName
DataFolder

Read only
C:\ProgramData\iBox\Index

The folder containing the index files. Should be set to a location with sufficient storage to contain the index.

DefaultsFileName

Read only

SearchIndexFileName

Read only

Identification
IndexUid

(unique id)

An unique ID that is used for identifying the index.

EventLoopInterval

30

How often the client polls for new events.

ListenTimeOut

60

Timeout in seconds. Defines the time for the client to wait for

Index Client

the server to answer.
PackageSize

65536

Package size (in bytes) which can be transferred from the
server to a client.

StreamingTimeout

300

300

Timeout in seconds. Defines the time to wait for writing a
PackageSize of data on a stream. Used when exporting or
importing an index or a model.

Logging
LogLevel

2

By increasing this value you increase the information chunk
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Default

Recommended

Comments

Auto Tagging

size that is logged in the index log file. Numbers 0-10 are
valid.
TransactionLogLevel

1

By increasing this value you increase the size of information
chunk about transactions in the index log file. Numbers 0-10
are valid.

TransactionLogMilliseconds

5000

If TransactionLogLevel is 0 or 1, the transactions will only
be logged if the time spent exceeds the TransactionLogMilliseconds value.

Misc.
CreateRootCategory

True

If set to False, no model root node will be created, and the
WorkZone Find ModelBuilder will not be able to create a
model.

MinSystemDriveFreeSpace

2048

The minimal amount of free space on the disk in MB. If this
amount of free space is not present, the WorkZone Find
Index service will stop.

SoftDeletedMaxAge

1

1

Number of days from the date when a block was soft deleted
until it is removed permanently (when a block gets soft
deleted the time is saved in the property softdeletetime).
Note: If you want to remove the softdeleted items manually,
set the value to 0. After this, open WorkZone Find Index Manager and click Tools > Remove old softdeleted iBlocks.

SummaryLength

320

The number of characters from the free text automatically
put in the Summary property when a block is saved.

WaitForGCMemoryLimit

0

Limit (in MB) of allowed memory consumption by the index.
When the limit is reached, the index will do garbage collection every 15 seconds. If the value is 0 (default), the fea-
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Default

Recommended

Comments

Auto Tagging

ture is disabled.
Search Index
AutoUpdateSearchIndex

True

If set to True, the search index will be updated when the new
blocks are added to the index store.

ExpandTagsInterval

300

This value defines the time interval (in seconds) for activating the job to expand tags. If this value is set to 0, the job
is disabled.

ImpersonateSearchCaller

True

If set to True, the caller’s identity is used when search queries are executed. If set to False, you have to specify SID in
the search query.

PersistSearchIndexInterval

1440

Interval (in minutes) between persisting the search index to
disk.

RebuildSearchIndexOnError

True

If set to True, the search index will be automatically rebuilt if
an error occurs during an update of the search index.

SearchIndexListening

False

If set to True, the search index is updated by event. This is
normally not necessary if the AutoupdateSearchIndex
value is set to True. Then it will update the search index
every second. If you set this value to True, the AutoupdateSearchIndex value will also be set to True.

SearchIndexLogLevel

2

If you increase this value, the logged information chunk size
will also be increased. Numbers 0-10 are valid.

SearchIndexTimeOut

0

Time (in seconds) before the search model is removed from
memory since it was last used. If the value is set to 0
(default), the search model will not be unloaded. Type -1 to
disable the search index.

13

WorkZone Find 2013
IndexSettingsC

Default

Recommended

Comments

Auto Tagging

SearchQueryLogLevel

1

If you increase this value, the information chunk size about
searches in the index log file will also be increased. Numbers
0-10 are valid.

UpdateSortIndexesInterval

60

Interval (in minutes) between updating the sort indexes for
the sortable property types.

Text Index - Plug-ins
TextIndexPlugins

List of text indexing plug-ins for the index. Each item is a full
class name pointing to a class that implements the interface
ScanJour.iBox.Index.Client.Text. If no plug-in is
defined, the default text index plug-in and the Lucene text
index plug-in are automatically added.

Transactions
MaxTransactionQueueSize

20

The maximal number of threads waiting to start a new transaction. When this limit is exceeded, all calls to “Begin Transaction” will return false.

TransactionTimeout

30

Transaction timeout (in seconds). Defines the time period
from transaction start until it is automatically stopped by the
index. Specify 0 to disable timeout on transactions.

TransactionTimeoutMode

Touched

Defines how the index should timeout a given transaction by
default.
Set to Start to measure timeout from the time when the
transaction was started. For example, when BeginTransaction
() was executed.Set to Touched to measure timeout from
the time when the transaction was active for the last time.
For example, when a DalC method was called.
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How to configure the Lucene settings
Configure Lucene settings as in the table below:

LuceneTextIndexSettings

Default

Comments

Files and Folders
DataFolder

<the same folder as the

ScanJour recommends you to locate the

index is located in>

Lucene index on the same location as the
index. If you move the index to another
drive, be sure that this data folder is
changed as well.

LuceneSubFolder

Text

The name of the subfolder containing the
LuceneData files.

StateFileName

Read only property showing where the
Lucene state file is stored.

Indexing of properties
DatePropertyIndexingStyle

OnlyDate

Options: DontIndexDateTimeProperties OnlyDate(Default) DateAndShortTime DateAndLongTime
This setting controls the granularity of indexing the date properties. “OnlyDate” means
that year-month-day is indexed while the
time is not searchable. Increasing the granularity will reduce the performance of the
index.

IndexedFields

All property types from the

The search plugin running in the service pop-

search model are automatically

ulates the empty list of fields. If you add
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LuceneTextIndexSettings

Default

added to the list

Comments

new properties and want to see them in the
list, then you must delete all items in the
list, save the settings and wait 15 seconds.

Indexing of properties – Settings for an index field
AnalyzeField

True

If set to True, an analyser is used when
indexing and searching on the field.

CustomAnalyzerTypeName

Empty

If a property should be indexed using a custom analyser, you can add the class identifier sting in this field.

Enabled
FieldAlias

True if property type is

Change this value to make the field search-

not searchable using other index

able (and rebuild the index).

Empty

If an alias is added, the alias should be used
when searching in the contents of the property type. If no alias is provided, the name
of the property type is used.

Uid

UID of the property type

This field links the settings to a property
type.

Plug-in
Description

Lucene Text Index plug-in

Enabled

True

Change this field to enable/disable the plugin. More than one plugin can be enabled
when indexing, but only one plugin can be
enabled when searching.

Uid

bf7ee6b5-8070-45df-825e-61b5d6f64b61

Query parser
DanishStopWords
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LuceneTextIndexSettings

Default

Comments

Danish words
EnglishStopWords

A list of commonly used
English words

ExtraStopWords

Empty list

You can add custom stop words for this setting.

UseDanishStopWords

True

Set to True to enable the list of Danish stop
words without clearing the list. Set to False
to disable the list.

UseEnglishStopWords

True

Set to True to enable the list of English stop
words without clearing the list. Set to False
to disable the list.

UseExtraStopWords

True

Set to True to enable the list of extra stop
words without clearing the list. Set to False
to disable the list.

Text Index
AutoUpdate

True

If set to True, the Lucene index will be
updated when the index store is changed.

AutoUpdateInterval

15

Time interval (in seconds) between the automatic updates of the index.

DefaultAnalyzer

Empty

When empty, the Lucene standard analyser
is used for analysing the free text of iBlocks.
If the field contains a class string of an analyser, this analyser is used.

LogLevel

0

Increasing this value will increase the
amount of information about the transactions in the index log file. Numbers 0-10
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LuceneTextIndexSettings

Default

Comments

are valid.
LuceneFieldContainingFullText

ft

The name of the Lucene field that contains
free text from the iBlocks.

LuceneFieldContainingID

id

The name of the Lucene field that contains
block ID of the indexed iBlock.

MaxFieldLength

0

If this number is positive and greater than 0,
then the Lucene will cut off the text in all
fields.

MaxRamIndexSize

0

Memory size (in MB). If this number is positive, greater than 0, and the complete
Lucene index is smaller than this size, then
the index will be loaded into memory. This
will optimize searching in small indexes.

MinWaitTime

1

Time (in minutes) to wait between updating
the index.

ReaderMinimalLifeTime

600

When the index is updated, the updates are
not visible before the index reader has been
closed and reopened. This setting defines
the time (in seconds) the index reader
should live before being closed.

ThreadPriority

Normal

The thread priority of the thread that
updates the Lucene index in OS.
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Configuring AD Connector
WorkZone Find AD ODBC Manager allows you to manage two non-repository connectors, namely
AD Connector and ODBC Connector.
How to configure AD and ODBC Connectors
1. Open WorkZone Find AD ODBC Manager.
2. Click the AD Connector tab.
3. Click Edit Settings.
4. In the AD Connector Settings window, click the AD Properties tab. On this tab you
can:
l

Add

l

Remove

l

Edit existing domains (LDAP) to be scanned by AD Connector.

You can also include multiple domains and enable or disable them (without removing
them) for scanning. Only the selected domains are available for scanning.
5. Click Add to add a new LDAP path.
6. Specify the login credentials and click OK.

7. On the AD Properties tab, ensure that the created domain is displayed in the domain
list along with the user information.
8. To create a schedule for automatically running AD Connector, click the Schedule tab.
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Note: Scheduling will be applicable to all the selected AD domains. It is not possible to
schedule the connector per domain.
9. To save the domain and scheduler settings, click Save settings.
10. The domains that are currently enabled, along with the schedule states are displayed on the AD Status tab in the Connector Current Settings section of the
WorkZone Find AD ODBC Manager window.
11. Click Start.
12. Wait until the connector has run successfully. A summary about the number of AD
groups and users created and updated in WorkZone Find is displayed.
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Changing Registry Settings on WorkZone Find Server
ScanJour recommends that you change the registry setting to ensure that the index services
are shut down properly when the machine is shut down.
To change the registry setting, perform the following steps:
1. Start the command prompt, type regedit and press Enter.
2. Open HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control
3. Set the WaitToKillServiceTimeout value to 300000.
Note: This should be done to ensure that the index services are shut down properly (not
terminated) when the machine is shut down.
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Enabling execution of ScanJourWorkZone Find Powershell scripts
The following steps need to be completed to enable specific Powershell scripts in
ScanJourWorkZone Find.
Preparations
1. Open Powershell as an administrator, and execute the following command SetExecutionPolicy RemoteSigned
2. Enter Y to confirm.
3. Check that the following directories respectively contain the powershell.exe.config
file. If this is not the case, you will have to create the powershell.exe.config file:
4.

l

c:\windows\system32\windowspowershell\v1.0

l

c:\windows\syswow64\windowspowershell\v1.0

Notes: The powershell.exe.config file must be encoded in UTF8 format. The file's content:
<?xml version="1.0"?>
<configuration>
<startup useLegacyV2RuntimeActivationPolicy="true">
<supportedRuntime version="v4.0.30319"/>
<supportedRuntime version="v2.0.50727"/>
</startup>
</configuration>
Notes: If the powershell.exe.config files are missing, executing the ScanJourWorkZone Find
powershell scripts may fail.
If you want to use CLR version 4 to load an assembly that was created with CLR version 1.1 or
2.0, include version 4 in the list of supported runtimes and set the
useLegacyV2RuntimeActivationPolicy attribute to true. This enables the .NET Framework
version 2.0 activation policy, which loads the assembly using the highest supported CLR version.
The .NET Framework version 2.0 activation policy is to load all assemblies by using the latest
supported version of the CLR. Starting with the .NET Framework 4, the default activation policy
is to cap this "roll-forward" behavior at the latest CLR version before version 4. In most cases,
the latest CLR version before version 4 is CLR version 2.0, which is used in all .NET Framework
versions from 2.0 through 3.5 SP1. This default policy loads most assemblies by using the CLR
version they were compiled with, providing greater compatibility.
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Configuring WorkZone Find Connectors
In this section you will learn about:
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Configuring WorkZone Find NTFS Connector
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Configuring WorkZone Find SharePoint Connector
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Configuring WorkZone Find ScanJour ECM Connector
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Configuring WorkZone Find EASY ENTERPRISE.x Connector
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Configuring WorkZone Find NTFS Connector
This section will guide you through the configuration of WorkZone Find NTFS Connector.
Perform the following steps:
1. Ensure that the WorkZone Find Index Server and WorkZone Find NTFS Connector services are running. Open WorkZone Find Connector Manager.
2. Click NtfsConnector and set the scan scope.
How to set the scan scope
1. Click Scan scope. The Scan scope configuration window is displayed.
2. Click Add. Enter the server name, on which the shared folders to be scanned by
WorkZone Find NTFS Connector are located. Click OK.
3. Ensure that the folders are listed on the Scan tab. Select the check boxes near the
required folders.
4. Click the Content tab.
5. Select the properties you want to extract and include in free text for the selected file
or folder.
6. Click OK.
7. Click Save.

3. Under Configuration, select Engine from the drop-down list. Set Force full rescan
value to True.
Click Start to perform a full scan.
Note: ScanJour recommends that you set AutoupdateSearchIndex and
AutoupdateTextIndex values to False during a first full scan.
Note: You must configure and run the AD Connector first; see Configuring AD
Connector.
4. The Summary tab will display a scan report.
5. Enable event handling (if applicable)
How to enable event handling
1. Under Configuration, select InformationProvider.
2. In the Misc section, set the Enable Event Handler value to True.
3. Click Save.
Because event handling is enabled, there is no need to perform full scans again,
unless the scan scope has changed. In that case a full rescan is required.
Because of the event handling, WorkZone Find index is automatically updated when
files are added, deleted or changed in the folders monitored by WorkZone Find.
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6. Set AutoupdateSearchIndex and AutoupdateTextIndex settings to True after
a first full scan.
How to verify WorkZone Find Server configuration
Follow the steps below to verify that NTFS and WorkZone Find have been installed correctly.
Test the NTFS settings
1. Open WorkZone Find Connector Manager.
2. Copy the “TestDocuments” folder from the WorkZone Find package into a network share so that WorkZone Find Admin has read access rights to it.
Note: You must use Advanced sharing, which is compatible with previous versions, if
WorkZone Find server is installed on a Windows 2008 system.
3. Set the scan scope to scan this location on the NTFS share.
4. Click Start.
Expected outcome: No errors. 6 folders and 28 files scanned.
Test Index settings
1. In the WorkZone Find Index Manager window, click the Search tab.
2. Delete all text, type “FindMeWorkZone Find” and click Search.
Expected outcome: 25 results.
Test free text search
1. Open the WorkZone Find Search page.
2. Free text search on “FindMeWorkZone Find”.
Expected outcome: 25 results
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Configuring WorkZone Find SharePoint Connector
To run WorkZone Find SharePoint Connector, the SharePoint Add-on must be installed on the
SharePoint server. Refer to the section Configuring SharePoint Add-on for more information.
To configure WorkZone Find SharePoint Connector, perform the following steps:
1. Ensure that WorkZone Find Index Server and WorkZone Find SharePoint Connector services are running. Open WorkZone Find Connector Manager.
2. Click SharePoint Connector.
3. Set the scan scope.
How to set the scan scope
1. Under Configuration, select Information Provider.
2. Click Scan scope.
3. In the Scan scope configuration window, click Add. Specify the name of SharePoint server (for example, \\ sp2010) and select the required node.
Note: ScanJour recommends you to click the Content tab, and verify that the
System node is available in the pane.
4. Click the Content tab. Select the properties you want to extract and include in free
text for the selected item in the tree.
5. Click OK.
6. Click Save in the WorkZone Find Connector Manager window.
How to enable event handling
1. Under Configuration, select Information Provider.
2. In the Properties pane, select Enable event handling.
3. Set the value to True.
4. Click Save.
The permissions to SharePoint resources are mapped to corresponding iBlock permissions in
WorkZone Find. For more information, see Mapping User Permissions from SharePoint

Managing Multiple SharePoint Connectors
If you use multiple SharePoint servers, ScanJour recommends you to install a separate SharePoint
connector for each server.
How to clone a SharePoint Connector
1. Navigate to the folder to which the WorkZone Find is installed, for example, C:\Program Files\ScanJour\WorkZone Find\Connectors\ MOSSConnectorService.
2. Start cloneConnector.cmd with Windows PowerShell.

27

WorkZone Find 2013

Note: To run the script execution of unsigned scripts must be enabled in
Windows PowerShell. This can be done giving the following command SetExecutionPolicy RemoteSigned.

See also the section Enabling execution of ScanJourWorkZone Find Powershell
scripts.
3. Specify the following parameters:
l

destinationFolderName – specify the name for the folder to which
the additional SharePoint Connector should be installed (for example,
MOSSConnectorService #2).

l

serviceName – specify the name of the service (for example, WorkZone Find SharePoint Connector #2).

l

portNumber – specify the port number (for example, 9845).

4. Press Enter.

5. Confirm starting the connector.
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6. Make sure that the folder for the connector has been created and the service is running.
When the additional SharePoint connector is installed, restart IIS.
How to uninstall a SharePoint Connector
1. Navigate to the folder to which the WorkZone Find is installed, for example, C:\Program Files\ScanJour\WorkZone Find\Connectors\ MOSSConnectorService.
2. Start removeConnector.cmd with Windows PowerShell.
Note: To run the script execution of unsigned scripts must be enabled in Windows
PowerShell. This can be done giving the following command Set-ExecutionPolicy
RemoteSigned.

3. Specify serviceName – the name of the service for the SharePoint Connector you
are goin g to delete (for example, WorkZone Find SharePoint Connector #2).

4. Confirm uninstalling of SharePoint Connector. The corresponding service as well as
the folder, to which the connector was installed, will be deleted.
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Mapping User Permissions from SharePoint
All permissions to SharePoint resources are mapped to the following information items
permissions in WorkZone Find: Read, Write, Tag, and Delete. This chapter includes the
description of the mapping process.
SharePoint Hierarchy
To map the permissions of users or user groups to WorkZone Find, it is required to extract the
specific data from each level of SharePoint hierarchy and merge them.
The hierarchy of SharePoint is as follows:

The following data are extracted from each level:
Level

Name

Extracted data

1

SPWebApplication

Policies for users and user groups.

2

SPSite

Site collection administrators list.

3

SPWeb

Permissions for users and user groups.

How to map user permissions
1. The permissions for users and user groups from Level 3 (SPWeb) are merged
and overridden by administrator permissions obtained from Level 2 (SPSite).
2. The obtained result is merged and overridden by policies for users and user
groups from Level 1 (SPWebApplication).
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Configuring WorkZone Find ScanJour ECM Connector
If you use product version lower than Captia 4.5 SP5, ScanJour recommends you to check if the
data dictionary contains the hasShadowSortField attribute defined on any <column> xml tag.
The presence of this attribute may affect the work of WorkZone Find ScanJour ECM Connector.
After scan, few iBlocks may be extracted from the ScanJour storage in case of insufficient buffer
size.
How to check for hasShadowSortField attribute
1. Open the customer source code in TFS.
2. Perform a search for the hasShadowSortField attribute in the data dictionary files.
3. In case the hasShadowSortField attribute is present, contact ScanJour for options.
The configuration procedure is similar if ScanJour ECM Connector is installed on a separate server
or if it is installed as a part of WorkZone Find server profile. If the WorkZone Find ECM Connector
is installed on a non WorkZone Find server, see Configuring WorkZone Find ScanJour ECM
Connector on a non WorkZone Find server.
How to configure ScanJour ECM Connector
1. Set up the connection to the ScanJour ECM database – see Setting Up the Connection
to ScanJour Database.
2. Add one or several servers to the scan scope.
3. For ScanJour ECM Connector, the node name must have the same name as the ScanJour ECM database.
4. Click Start Scan.
Select the properties you want to be extracted and/or included in the free text on the
Content tab.
5. Restart the WorkZone Find ScanJour Connector service.
6. Specify the DefaultSecurity setting for ScanJour ECM Connector in WorkZone Find
Connector Manager with the SID of the AD group that has access to all register items
(casefiles, documents, and so on) in ScanJour ECM, which are not secured with any
access codes.
Enabling Eventing to create triggers
1. To start the event handler, set the value of the EventHandler property to True.
Note: If your company has Journalmodulet, refer to section Enabling Eventing for
Journalmodulet before proceeding.
2. Click Save.
3. Wait for triggers to get created in the database. The Debug Mode View section
displays the triggers created in the database. While the triggers are being created,
WorkZone Find Index Manager will not be available.
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4. Set the value of the EventHandler property to False to stop the event handler.
5. Click Save.

7. See topic Resolving Captia Data Issues for information on how to check for data
issues.
Additional step for Version G only
The search UI in WorkZone Find includes links to the items that are found in the search.
SjIntranet in Version G does not natively support http links to individual items, but a
custom solution exists. If such a custom solution is installed, you can modify the templates
that generate the links in WorkZone Find. You can do this in the ScanJour Information
Provider settings. The ScanjourBlockSettingsArray property contains LinkUrn for
fileclass, casefile, contact and document. You should change these settings to reflect the
custom solution.

Configuring WorkZone Find ScanJour ECM Connector on a non WorkZone Find
server
If you have installed ScanJour ECM Connector on the machine that is not the WorkZone Find
server (for more information, see the section Installing ScanJour ECM Connector in the
Installation_Guide), follow the procedure below to configure ScanJour ECM Connector.
First, you must configure the user running the WorkZone Find ScanJour Connector service. If
WorkZone Find ScanJour ECM Connector is installed on a machine that is not the WorkZone Find
server, then the user running WorkZone Find ScanJour ECM Connector service needs to have
Network Access. Refer to the InstallGuide_PreInstallChecklist document and check the
prerequisites.
How to configure the user account
1. On the machine where ScanJour ECM connector is installed, open Services.
2. Right-click WorkZone Find ScanJour Connector Service and select Properties.
3. Click the Log On tab and select This account under Log on as. Specify credentials of the user (for example, domain\administrator), who has the Network
Access rights. Type the password and confirm it.
4. Click OK.
How to specify the remoting address of the index
1. On the machine where ScanJour ECM Connector is installed, open WorkZone
Find Settings Editor.
2. In the IndexSettingsC window, select All Users.
3. From the Section drop-down list, select IndexSettingsC.
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4. Under Distributed, find the RemotingAddress setting.
The remoting address format is as follows:
tcps:\\<server>.<domain>:<port number>/index
If the field contains the remoting address of the index, leave it as is. In other case,
copy the value of this setting from WorkZone Find server and paste it into this field.
On WorkZone Find server, you can find the RemotingAddress setting in the same
section of the IndexSettingsC window. For more information, see Configuring Index
Settings.
Note: You can find the remoting address on WorkZone Find server only in case the
WorkZone Find Index service has been started at least once.
Click any other field and click Apply.
How to configure ScanJour ECM Connector
1. Set up the connection to the ScanJour ECM database – see the section Setting Up the
Connection to ScanJour Database.
2. Add one or several ODBC DSNs to the scan scope.
3. On the Content tab, select the properties you want to be extracted and/or included
in the free text.
4. Restart the WorkZone Find ScanJour ECM Connector service.
5. Specify the DefaultSecurity setting for ScanJour ECM Connector in WorkZone Find
Connector Manager with the SID of the AD group that has access to all registeritems
(casefiles, documents, and so on) in the ScanJour ECM, which are not secured with
any access codes.
Enabling Eventing to create triggers
1. To start the event handler, set the value of the EventHandler property to True.
Note: If your company has Journalmodulet, refer to the section Enabling Eventing
for Journalmodulet below before proceeding.
2. Click Save.
3. Wait for triggers to get created in the database. The Debug Mode View section
displays the triggers created in the database. When the triggers are being created,
WorkZone Find Index Manager will not be available.
4. Set the value of the EventHandler property to False to stop the event handler.
5. Click Save.
Refer to sectionResolving Captia Data Issues for information on how to check for data issues.
Additional step for Version G only
The search UI in WorkZone Find includes links to the items that are found in the search.
SjIntranet in Version G does not natively support http links to individual items, but a custom
solution exists. If such a custom solution is installed, you can modify the templates that
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generate the links in WorkZone Find. You can do this in the ScanJour Information
Provider settings. The ScanjourBlockSettingsArray property contains LinkUrn for
fileclass, casefile, contact and document. You must change these settings to reflect the
custom solution.

Performing Initial Scan Using ScanJour ECM Connector
The procedure of initial scanning the ScanJour ECM database by the WorkZone Find ScanJour
ECM connector is quite complicated and requires system, network, and database resources.
Note: For successful scanning of the database, complete the conditions listed below.
Define the structure of the model
You have to define the structure of the model with the customer and specify which properties
will be used for populating the model in the Scan scope configuration dialog box.
If you select all available properties (some of which are not required to be processed), this
will lower the performance of scanning and all other index operations.
Check the links to the ScanJour items
Links are generated on the basis of information about the web server and database name,
which are retrieved through SOM.
This information can be outdated in ScanJour ECM configuration, and therefore may need to
be adjusted.
Note: The links cannot be changed without rescanning. You can do a pre scan (seeHow to
perform a pre scan) and test that links are working on all items.
Estimate the time of scanning
You need to make pre scan time estimation, because it may be required to make some
scheduled backup or other maintenance tasks that may affect the scanning procedure.
Note: Processing of documents takes longer time then processing of other objects, since free
text needs to be extracted. During the ideal pre scan, the same percentage of documents as
exist in the whole database must be scanned.
Data issues in the ScanJour database
ScanJour ECM Connector uses SOM to read data in the ScanJour database, and all data in the
database should therefore be readable by SOM.
However, it may occur that not all data in a ScanJour database has been created by SOM. This
situation arises if:
l

The database was not created in the current version, but upgraded from a previous
version.

l

There are database level integrations that populate or update data in the database.

l

There are other integrations or add-ons, which bypass SOM.

l

AD contains invalid data that is replicated to the ScanJour database. Refer to section
How to find the data issues in the ScanJour Database for more information on how to
deal with this issue.

When these conditions are fulfilled, you can start performing the pre scan and full scan.
How to perform a pre scan

34

Configuration Guide
You can perform two types of pre scan:
l

Quick pre scan: By performing this type of pre scan, you can define if the procedure
runs correctly within a few minutes. However, not all the items in the database will be
scanned.

l

Standard pre scan: When performing this type of pre scan, you have to set the scan
focus on one file class containing a few case files with documents, which include the
diversity of items. This will take more time, but the results will be more precise.

How to perform a quick pre scan
1. Set the Buffer size value to 100. This will provide quicker response but will make
the scan slower.
2. Click the Start button. The database will be scanned according to the following
structure:
1.1 File classes
1.1.1 Case files
1.1.1.1 Documents
1.2 Contacts
3. After a few minutes have elapsed, click Stop.
How to perform a standard pre scan
Before you perform standard pre scan, you must set the following two parameters for each
item type:
l

SearchCriteria

l

SearchCriteriaField

Follow the steps of the procedure described below to perform a standard pre scan (The SQL
used in the example below is typical for Captia 4.x).
1. Run the following SQL query to find the class key:
SELECT file_class_key
FROM fcs
WHERE file_class = ‘<File class name>’
2. Start the ScanJour ECM Connector. In the ScanJourBlockSettingsArray field,
click the

button.

3. In the ScanJourBlockSettings Collection Editor dialog box, specify the value
found on step 1 into the field SearchCriteriaField (in the example below, the
value is 28).
4. Specify the file_class_key value in the SearchCriteriaField
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How to perform a full scan
To perform a successful full scan, disable the processes and stop the services described
below.
When you start eventing for the first time, a table is populated with information about the
date/time when the ScanJour database items were changed for the last time.
Important: If the database you are scanning is a production database, all the events on items
that had been scanned before you started eventing for the first time, will be lost.
Therefore, you have to start eventing and stop it again before performing the full scan. You
must do this when the database is not being updated. Otherwise, it might trigger some
entries in the error log file.
How to disable unnecessary jobs
DISABLE THE SEARCH INDEX AUTO UPDATING

Perform the following steps to disable the search index auto updating:
1. Click File > Index Settings.
2. From the Section drop-down list, select IndexSettingsC.
3. In the Search Index section, set the AutoUpdateSearchIndex value to
False.
4. In the Search Index section, set the SearchIndexlistening option to False.
5. Click Apply.
DISABLE AUTO TAGGING
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Perform the following steps to disable auto tagging:
1. In the IndexManager window, click File > Index Settings.
2. In the IndexSettingsC dialog box, set the AutoTaggingInterval value to “0”.
STOP UNNECESSARY SERVICES

There are two WorkZone Find services which are required to run during the full scan
procedure:
l

WorkZone Find Index service

l

WorkZone Find ScanJour Connector service

To stop the unnecessary processes, perform the following steps:
1. Press <Win+R>.
2. In the Run dialog box, type Services.msc and click OK.
3. Stop all the WorkZone Find processes except WorkZone Find Index and WorkZone Find ScanJour ECM Connector.
Note: When the scan is performed, enable all the jobs you have disabled before starting the
scan.
How to find the data issues in the ScanJour Database
Below is the list of the four most common issues which may occur during the full scan
procedure.
ISSUE 1: POSTAL CODE IS NON-EMPTY, BUT COUNTRY CODE IS EMPTY

Run the following SQL query to detect this issue:
For Captia 3/ScanJour version G:
SELECT COUNT(*)
FROM navneadresse
WHERE postnr IS NOT NULL
AND landkode IS NULL;
For Captia 4.X:
SELECT COUNT(*)
FROM name_address
WHERE postcode IS NOT NULL
AND country_code IS NULL;
This may be caused by the AD connector that produced the empty country code. For example,
when the country code is copied from AD by the AD connector and some employees have an
empty country code in the AD.
To avoid the erroneous data, which may reappear while running the AD connector, fix this issue
in AD.
ISSUE 2: RECORD TYPE IS EMPTY OR CONTAINS SPACE CHARACTER
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If the record type is not specified, the corresponding error message is added to the log. To
detect the records for which the record type is not specified, execute the following SQL
queries:
Captia 3.0/ScanJour version G
SELECT COUNT(*)
FROM akt
WHERE akttype IS NULL or akttype = ‘ ‘;
Captia 4.X
SELECT COUNT(*) FROM fcs
WHERE file_class LIKE '%?%'
OR file_class LIKE '%*%'
ISSUE 3: BLOCK TYPE ICONS IN THE SCANJOUR CONNECTOR

When the connector starts, the block types and the icons are created. If you create a new
block type, the
icon will be attached to it. This icon will be attached to all the document
file types in the block type.
How to analyze the results of the scan
After you have performed the procedures described in the section How to perform a full
scan, open WorkZone Find Connector Manager and click Start. When the scan has
been completed, enable eventing and all the disabled jobs.
When the full scan is completed, check the log files to make sure that the procedure has
been completed successfully.
There are two events log files produced by the ScanJour ECM Connector:
l

iBoxSJConnector.exe_Log

l

iBoxSJConnector.exe_Error

To view the logs, go to ProgramData>iBox>Log.
IBOXSJCONNECTOR.EXE_LOG

This log contains information about all scanned items and warnings. A warning is added to
the log if AD has not been scanned. To view the log of the full scan procedure, run:
C:\ProgramData\iBox\log\>FIND
/I “Unknown SID ignored” iBoxSJConnector.exe_Log.txt
SIDs of the users which are available in ScanJour ECM, but have not been found in
WorkZone Find during scanning will be displayed. If there are any of these SIDs, you
should investigate why they are in the ScanJour database, but not in AD (or if it is the
correct AD that has been scanned by the WorkZone Find AD connector).
IBOXSJCONNECTOR.EXE_ERROR

If the full scan procedure has been completed successfully, this log must be empty. There
also can be minor error messages caused by data problems in the ScanJour database.
If the log contains System.Runtime.InteropServices.COMExceptions, you have to
define the ScanJour data problem. Find the following strings:
Register: <name of ScanJour register>
Systemkey: <system key of register item>

38

Configuration Guide
This will reveal which ScanJour item caused the problem.

Enabling Eventing for Journalmodulet
This section is only applicable if your company has Journalmodulet.
By default WorkZone Find is set up to react on changes in the ScanJour repository. For this purpose
a trigger has been implemented on main tables, reacting to changes in the updated field(s).
When working with ScanJour ECM (which is based on SOM), this is default functionality. For
example, when a field is assigned a new value, SOM updates the Update field.
For Journalmodulet (the Journal module) this works in a different way.
EVENTING IN JOURNALMODULET

For Sagsmodule (the Case module) and Intranet everything works the same way as for Captia
(because they use SOM). However, for Journalmodulet all updates are performed by the application
itself because Journalmodulet does not use SOM.
Therefore, when changing a value in, for instance, the register “SAG” (case), the value is changed,
but the Updated field is not updated, and an event is not raised.
Because of this, WorkZone Find will not be aware of the change and will not update the
corresponding iBlock.
How to enable eventing in Journalmodulet
1. Open WorkZone Find Connector Manager and click ScanJour Connector.
2. Under Configuration, select InformationProvider. Set the EventHandlerproperty value to False.
3. Click Save.
4. Open WorkZone Find Connector Manager.
5. Under Configuration, select InformationProvider.
6. Near the ScanjourBlockSettingsArray property, click the

button.

7. In the ScanjourBlockSettings Collection Editor window, perform the following
steps for each member (except database):
1. Near the Tablesettings property, click the

button.

2. For each member, select the Field property and delete the value.
3. Click OK.

8. Click OK in the ScanjourBlockSettings Collection Editor window.
9. Click Save.
10. Stop the WorkZone Find ScanJour Connector service.
11. Click Save.
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12. Install WorkZone Find ScanJour ECM database scripts (see section Run the Register update script).
13. Start the WorkZone Find ScanJour Connector service.
14. In WorkZone Find Connector Manager, select ScanJour Connector.
15. Under Configuration, select InformationProvider. Set the EventHandler
property to True.
(Check that the triggers are installed on the ScanJour database in the Debug
Mode View section of the WorkZone Find Connector Manager window).
16. When you have installed the triggers, set the EventHandler property to False.
The Event handler must be disabled during initial full scan.

Configuring the Settings to Trigger the Event on the Field Change
The change of the field on Version G server can trigger an event in WorkZone Find. This section
describes how to configure the settings to trigger the event.
1. Open WorkZone Find Connector Manager and click ScanJourConnector.
2. Under ScanJour settings, select the ScanjourBlockSettingArray setting and click
the

button.

3. In the ScanjourBlockSettings Collection Editor dialog box, under Members
select the required item.
In the properties section under Tables, select TableSettings and click the

but-

ton. The TableSettings Collection Editor dialog box opens. It contains the following elements:
1. The Members pane – contains the list of the tables describing the
item properties;
2. The Properties pane – contains the list of table properties.
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On the Properties pane under Misc, find the Fields setting.
It contains the list of table fields (from the database) which correspond to the specific
fields in Journalmodulet.
If one of the values specified in this field is changed in Journalmodulet and eventing is
enabled, the corresponding event will be triggered in WorkZone Find.
The event details are displayed in the Debug Mode View section of the WorkZone
Find Connector Manager window.
If the Fields setting does not contain any values, the event will be triggered in
WorkZone Find when any field in the selected table changes.
4. To trigger the event in WorkZone Find if any of the fields for in Journalmodulet
changes, clear all the values from the Fields text box.
5. Restart the ScanJour ECM Connector service.

Setting Up the Connection to ScanJour Database
You have to complete the following steps to set up the connection to ScanJour database:
Install the Oracle client
WorkZone Find ScanJour Connector uses an Oracle 11 client, and not all of the supported
ScanJour ECM versions include this client. Therefore, it is required to install the Oracle 11 client.
Note: If the Oracle 11 client is already installed, skip steps 1-3 and go directly to step 4 below:
1. Go to the default installation directory and find OracleClientInstallation.msi.
On a 64 bit machine this folder is located on:
C:\Program Files\ScanJour\WorkZone Find\Connectors\SJConnectorService
2. From the command line run:
…\SJConnectorService\>msiexec /I OracleClientInstallation.msi
3. The installation modifies the system path.
Therefore, you should restart the command shell.
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4. Add all data sources that are to be used by the connector in tnsnames.ora. This
file is located in
C:\Program files\ScanJour\WorkZone Find\<OracleFolder>\network\Admin.
Example:
The tnsnames.ora file may contain the following:
DB01 =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)
(HOST = Captia DB)
(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = DB01))
)
Set up data sources for ScanJour databases
You must add an ODBC alias for SOM to access the data sources.
1. Use the odbcad32.exe Windows tool. It is located on:
C:\windows\syswow64\odbcad32.exe – for 64 bit operating systems;
C:\windows\system32\odbcad32.exe – for 32 bit operating systems.
2. In the ODBC Data Source Administrator window, click the System DSN tab.
Click Add.
3. In the Create New Data Source dialog box, select Oracle in Ora 11g driver
from the list. Click Finish.
4. In the Oracle ODBC Driver Configuration dialog box, specify the data source
name and description.
From the TNS Service Name drop-down list, select the data source to be used
by the connector.
5. Click Test connection.
In the Oracle ODBC Driver Connect window, specify the user name and password for the Oracle database. Click OK. The connection will be verified.
6. In the message box, click OK.
7. For ScanJour Captia 3.0 and ScanJour Version G
If you are running Captia 3.0 or Version G, then add the data sources to
scanjour.ini file. For Version G it is located on C:\ScanJour\Program\.
For ScanJour Captia 3.0 it is located on C:\Program
Files\scanjour\captia\program.
Note: on 32 bit machines this file is located on C:\program files (x86)
\scanjour\captia\program.
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8. For ScanJour Version G only
Sometimes the archive uses separate data source – you must also add this DSN.
You can find the name in the ScanJour database in table sj_arkivid.
Open ScanSQL and execute the following SQL statement:
SELECT initstreng FROM SJ_ARKIVID
This will return the following:
/d:qa083 /b:SJ_ARKIV /a:SJ_ARKIV /arkiv:SJARKIV /index:context
9. The DNS name is located after /d: - in this case it is qa083. You will need to connect
to this DSN while running the update script, see Run the Register update script.
Run the Register update script
1. Go to the database scripts in the SQL subfolder of the SJConnectorService folder.
In a typical installation this is:
C:\Program Files\ScanJour\WorkZone Find\Connectors\SJConnectorService\SQL
2. Run registerupdate.sql as the database user sjsysadm. Follow the provided instructions.
Example of executing script:
…\SJConnectorService\SQL>sqlplus sjsysadm/sjsysadm@database
@registerupdate.sql

3. When asked to “Enter folder for output without terminating”, enter the path where
log file from this script is written. Note that this folder must already exist.
After the script is executed, a log file will be created in the log folder named registerupdate.txt.
If the script has been executed successfully, the log file only contains errors like
“Item already exists”.
4. For ScanJour Version G only
This installation step should only be performed on ScanJour version G.
Example:
…\SJConnectorService\SQL>sqlplus sjsysadm/sjsysadm@database
@archiveUpdateVersionG.sql

Testing the Connection
Before starting ScanJour ECM Connector, it is important to test that the connector can connect to
the created DSN. Perform the following steps:
1. Open a command prompt and find the ScanjourConnector Tool in the connector service
folder. On a 64 bit machine this folder is as a rule located on:
C:\Program Files\ScanJour\WorkZone Find\Connectors\SJConnectorService
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2. To do the test, run the tool with the following command line parameters:
1. connect
2. dsn: Name of ODBC DSN for the connection
3. sjsysadmpwd: password for the sjsysadm user
3. If the configuration is done correctly, the tool will reply OK.
Example:
C:\>ScanjourConnectorTool.exe connect <dsn> <sjsysadmpwd>
OK
C:\>
Testing the connection has the advantage that the data source will be known by the
connector when you start the ScanJour Connector service and the WorkZone Find
Connector Manager.

Using iFilters with the ScanJour ECM Connector
Normally ScanJour ECM Connector extracts free text for documents by using the ScanJour
generated free text from the table register_text in the ScanJour database. ScanJour
recommends using iFilters only in case you have a special need for this.
The FreetextExtractionMethod setting enables the ScanJour Connector to generate free text
in the same way as NTFS by using iFilters.
How to find the setting
1. In the WorkZone Find Connector Manager, click ScanJourConnector.
2. Under Configuration, select InformationProvider.
3. For the FreetextExtractionMethod property you can select one of the following
values:
1. iFilters
2. VersionGOracle
3. Captia
If you are running ScanJour version G, the default value is VersionGOracle.
If you are running Captia, the default value is Captia.
How to extract free text using iFilters
1. Change the value of the FreetextExtractionMethod to iFilters as described
above.
2. Ensure that the WorkZone Find ScanJour Connector service is running as the
same user as the free text extraction COM+ packages (usually admin).
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How to check the user
1. Open Windows Services.
2. Right-click WorkZone Find ScanJour Connector and select Properties.
3. On the Log On pane, select the This account option button.
4. Type the credentials for the user running the WorkZone Find free text extraction
COM+ application.
5. Click OK.
6. Restart the WorkZone Find ScanJour Connector service.

3. Ensure that iFilters are installed on the server running the ScanJour ECM Connector.
If you are running the connector on a 32 bit server, you must ensure that you have
32 bit iFilters. Refer to Appendix A in the Installation_Guide.
4. If you are running ScanJour Captia, change the freetextmergehandlerstring for
the record to $$ft$$ .
How to change the setting
1. In WorkZone Find Connector Manager, click ScanJourConnector.
2. Under Configuration, select InformationProvider.
3. Select the ScanjourBlockSettingsArray property.
4. Select the Record member.
5. On the right side select freetextmergehandlerstring and change its the value
to $$ft$$.
6. Click OK.
7. Click Save.
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Configuring WorkZone Find EASY ENTERPRISE.x Connector
Configuring WorkZone Find EASY ENTERPRISE.x Connector assumes knowledge of the EASY
ENTERPRISE.x archive system to be used, and of EASY DOCUMENTS. Installation and
configuration notes to these systems are not part of this documentation; please refer to EASY
ENTERPRISE documentation and training courses.
A number of configuration activities are necessary in the EASY ENTERPRISE.x archive system to
implement archive connectivity using WorkZone Find EASY ENTERPRISE.x Connector. Please
refer to the section Preparing EASY ENTERPRISE.x archive system for WorkZone Find
connectivityfor further information.
To configure WorkZone Find EASY ENTERPRISE.x Connector, see Configuring WorkZone Find
EASY ENTERPRISE.x Connector in Connector Managerand Working with WorkZone Find
Connector Manager.
If multiple EASY ENTERRISE.x archives are to be scanned, please refer to Managing Multiple
EASY ENTERPRISE.x Connectors.

Preparing EASY ENTERPRISE.x archive system for WorkZone Find connectivity
Create WorkZone Find permissions database
Since the option to directly send the permissions to WorkZone Find via the archive interface
is currently not yet available, it is necessary to save the permissions in a separate database
when saving and deleting documents.
1. Create the EASY_iBOX database using an SQL editor, e.g. Microsoft SQL Server
Management Studio.
2. In the created database, create a table named document_properties using the

following notation.
Note: The file document_properties.sql in the folder C:\Program
Files\ScanJour\WorkZone Find\Resources\Scripts\EASY ENTERPRISE.x
integration\SQL is a template script for Microsoft SQL Server to create the
required table.

Create DBCONNECTION in EASY ENTERPRISE.x
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The DB-Connection class is used to make connections to external databases and execute queries
there. If the external database is not the database that is used by the EASY ENTERPRISE.x
system, the EASY ENTERPRISE.x system must be made aware of the external database's
corresponding driver in advance using CLASSPATH entries.
Setting up access to the external WorkZone Find database EASY_IBOX
To use external databases, a database connection pool is needed. Using e.g. Microsoft SQL
Server, perform the following steps.
1. Start Configuration Manager and add a template to the Configuration Database node
by right-clicking Edit and Upload Template ....

2. Select a corresponding template for the database used, and add the mask that follows to the input.
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Note: Make sure that the DB connection name is the configuration database's
subnode, not the DNS name of a removed server.
3. After the template has been augmented and incorporated, a subnode with a name
that corresponds to the allocated DB connection name is created below the configuration database's Resources/Database server.
4. Remove the DocumentDbMapping, Symbols and Tables subnodes from the
created node.
5. Add the PUBLIC property of the Boolean value data type with the value TRUE.
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For more information on creating databases within the archive system, see the documentation
on EASY ENTERPRISE.x EE.x-Scripting_en.pdf, and others.
Integrating and Customizing Scripts
1. Create a folder named iBOX in the Configuration Manager's Scripts node. This folder
is referred to in scripting.
Note: If another folder is to be used, it is imperative that you customize the scripts.
2. Now the following java scripts need to be imported:
l deletedocid.js
l

library.js

l

savedocid.js

l

sync.js

Notes: Templates for the scripts are located in the folder C:\Program
Files\ScanJour\WorkZone Find\Resources\Scripts\EASY
ENTERPRISE.xintegration\Event Handlers\.
The script and folder names must be identical with respect to case, underscores etc.
In the library.js script, customization of basic settings is necessary regarding
databases, accesses to databases and table names.
In the sync.js script, customization of the schema and the pool is necessary. This
script is used to initially write the permissions of an archive that already exists in
the Permissions database or to cyclically communicate permission changes to the
iBOX pool.

Customizing Schemas
To trigger the eventhandler in ScanJour WorkZone Find the scanned schemas must be made
aware of the above scripts. After adding or deleting documents, an entry will be created or
updated per file in the created database.
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1. Assign the script deletedocid.js to the script event onAfterDelete:

2. Assign the script savedocid.js to the script event onAfterSave:

If the archive already contains data, the corresponding permissions can be transferred to the
database using sync.js .
For more information on EASY ENTERPRISE.x scripting engine, see the documentation on
EASY ENTERPRISE.x EE.x-Scripting_en.pdf, and others.

Configuring WorkZone Find EASY ENTERPRISE.x Connector in Connector Manager
Make sure that the EASY ENTERPRISE.x archive system is prepared for connectivity before
working with the connection in ScanJour WorkZone Find Connector Manager, see the section
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Preparing EASY ENTERPRISE.x archive system for WorkZone Find connectivity.
Configuration and setup for deploying information from EASY ENTERPRISE.x archives are
performed in ScanJour WorkZone FindConnector Manager. Connector Manager is the interface
between WorkZone Find and external resources. The credentials and configurations for reading the
data can be set here for each interface. See also Working with WorkZone Find Connector Manager.
Basic Settings
To pair ScanJour WorkZone Find with the EASY ENTERPRISE.x archive, basic settings is
configured in Connector Manager.
1. Open ScanJour WorkZone Find Connector Manager.
2. Select the relevant connector in the panel to the left.
3. In the upper right corner of the window select Information Provider in the dropdown.
4. Find the section EASY XML Server Connections and click Connections and then ....
5. Add the EASY ENTERPRISE.x archive server.
Note: The Connections node allows connecting any number of archive servers.
6. Close the editor by clicking OK.
7. Click Save in the lower part of the Connector Manager window.
8. Now fill in the fields according to the table below:
Variable
XML Server
URL

Explanation
EASY ENTERPRISE.x XML Server URL

Example
http://127.0.0.1:8080/eexxmlserver/eex-xmlserver/

Name of a technical archive user
Username

who can access the corresponding

superadmin

archives
Password
Scope
Database Connection String
Database Connection Provider

********
Search sources

Data Source=1-

[document_properties] to read the

27.0.0.1;Integrated Secu-

permissions per file.

rity=True

E.g.: System.Data.Sqlclient
(MSSQL Connection Provider)
Database and table name for the con-

Properties

nection to the entered permissions

Table

per file.

extensions

page)

Access definition for the database

Document

Freetext file

Search sources (see next

System.Data.SqlClient

[EASY_iBOX].[dbo].[document_properties]

Listing the file extensions which are
used as full text source for search/re- html, docx, ...
trieval.
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Freetext

Maximum number of freetext char-

length limit

acters to retrieve

Freetext timeout limit

16777216

Maximum number of miliseconds to
allow for freetext extraction for an

20000

item

9. Click Save in the lower part of the Connector Manager window.

Setting up the Scope for the Connector
Defined archives (pool/schemas) can now be configured per server via the Scope node.
Note: The first time the Scope node is clicked an error message will appear Just close it,
click Save and continue.

1. Click the connection number to open it, e.g. [0].
2. Click Scope and then ....
3. Checkmark the schemas to be scanned.
4. Click the name of the schema to edit the properties.
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Notes: The Viewer URL is used for quick view configuration to open the selected
document/file directly in EASY EXPERIENCE.x or EASY DOCUMENTS. For every
archive it can be determined which quick view to use for displaying the hits.
DOCUMENTS:
http://easy-ibox:8090/jsp/qv?pri=peachit
&amp;vw=PRESSE&q_ROOTID=${ROOTID}
Example:
http://easy-ibox:8090/jsp/qv?pri=peachit
&amp;vw=PRESSE&q_ROOTID=${ROOTID}
EXPERIENCE:
http://easy-ibox:8080/experience/Experience.html?
MQ&NT&NN&RO&view=PRESSE&F_${SCHEMANAME.ROOTID
=${ROOTID}
Example:
http://easy_ibox:8080/experience/Experience.html?
MQ&NT&NN&RO&View=PRESSE&F_PRESSE.ROOTID=${ROOTID}
5. Save ScanJour WorkZone Find EASY ENTERPRISE.x Connector configuration by clicking Save.

overskrift

Creating schema-specific properties
To make ScanJour WorkZone Find aware of new fields from a schema, the following steps and
prerequisites are necessary. In ScanJour WorkZone Find, properties are displayed during
mapping according to the following aspect: For date fields within the schema, only properties of
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the Date type are displayed in ScanJour WorkZone Find. For text fields within the schema,
only properties of the Text type are displayed in WorkZone Find.
1. Prerequisites:
l

The Index field attribute must be True for the corresponding field.

l

Fields to be used must be defined for the schema as hit list fields.

2. You need to verify that the C:\Program Files\ScanJour\WorkZone
Find\Connectors\EexConnectorService folder contains the
propertydefinitions.xml file. If this is not the case, it must be created as
follows:
1. Terminate the WorkZone Find EASY ENTERPRISE.x Connector
Service service.
2. Create the propertydefinitions.xml file:
l
l

Start the Cmd program as an administrator.
Go to this directory: C:\Program Files\ScanJour\WorkZone
Find\Connectors\EexConnectorService.

l

Run Powershell–file GetProperties.ps1.
Note: To run the script execution of unsigned scripts must
be enabled in Windows PowerShell. This can be done giving
the following command Set-ExecutionPolicy
RemoteSigned.
See also the section Enabling execution of
ScanJourWorkZone Find Powershell scripts.

3. Existing properties are read from ScanJour WorkZone Find and deployed in the
propertydefinitions.xml file. This file can now be opened, e.g. in Notepad++.
Ensure that the mapping between EASY ENTERPRISE.x Connector data type and
the data type in the propertydefinitions.xml file is correct.
4. Open the PropertyDefinition.xml file with an editor, e.g. Notepad++, to add attributes.
5. Create a new section named <PropertyDefinition>:
<PropertyDefinition>
<Uid>36373c75-9900-4465-8c5c-20c9961b9574</Uid>
<Name>MY-ATTRIBUTE</Name>
<Description>DESCRIPTION</Description>
<Type>String</Type>
<Searchable>false</Searchable>
<SearchSortable>false</SearchSortable>
<Indexable>false</Indexable>
</PropertyDefinition>
Allowed values for Type are:
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l

Int32

l

DateTime

l

String

l

Boolean

Note: It is important to generate a new unique ID. Tools for UID generation are
available as freeware, e.g. Google UUIDgenerator.jar.
6. Save the PropertyDefinition.xml file.
7. Restart the ScanJour WorkZone FindIndex Service.
Note: All dependent services restart automatically.
8. Start the ScanJour WorkZone Find EASY ENTERPRISE.x Connector Service.
9. Open ScanJourWorkZone Find Connector Manager.
10. Go to Connection > Scope to verify that the new property is listed.
11. The new property can now be used for ScanJour WorkZone Find.

Managing Multiple EASY ENTERPRISE.x Connectors
If you use multiple EASY archive servers, ScanJour recommends you to install a separate EASY
ENTERPRISE.x connector for each archive.
How to clone an EASY ENTERPRISE.x Connector
1. Navigate to the folder to which the WorkZone Find is installed, for example, C:\Program Files\ScanJour\WorkZone Find\Connectors\EexConnectorService,
and copy it.
2. Save it with a different name e.g. EExConnectorService2 in C:\Program
Files\ScanJour\WorkZone Find\Connectors.
3. Find EcfService.exe.config file inside the folder and open it in an editor, e.g.
Notepad++.
4. Find the section ServiceSettings and specify the following parameters:
l

ServiceName – specify the name of the service (e.g., WorkZone Find
EEx Connector Service2).

l

RemotingPort– specify a new port number (e.g. 9851).

l

fileName – change the name for logfiles for the targets info, error, performance, and blockcache (e.g EExConnector2_${shortdate}_performance.log).
Note: Make sure the port is not used for anything else.

5. Delete the section system.serviceModel. This section is regenerated when the
service starts.
6. Save the file.
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7. Find the installService.cmd file inside the same folder and open it in an editor,
e.g. Notepad++.
8. Specify the following parameters:
l

Name – specify the name of the service according to step 4.

l

DisplayName – specify the name of the service according to step 4.

l

Description – enter a description accordingly.

9. Save the file.
10. Execute the InstallService.cmd file in the cmd prompt.
11. The prompt returns Success.
12. Ensure that the new EASY ENTERPRISE.x Connector service appeared in services.
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Configuring SharePoint Add-on
This section describes how to configure the SharePoint add-on installed on the SharePoint server.
You need to configure the SharePoint add-on before configuring WorkZone Find SharePoint
Connector on the WorkZone Find server.
Before you start configuring the scan scope, you have to configure the Windows Firewall settings so
that WorkZone Find SharePoint Access Service could be accessed from WorkZone Find Server.
How to configure Windows Firewall settings
1. On the SharePoint server, click Control panel > Windows Firewall.
2. On the Control Panel Home page, click Allow a program or feature through
Windows Firewall.
3. On the Allow programs to communicate through Windows Firewall page,
select the checkboxes near proper network types for WorkZone Find SharePoint
Access Service.

4. Click OK.
The WorkZone Find Search control integrates the WorkZone Find Web Search Page with
SharePoint 2010 as WebPart Deployment.
You have to configure the WorkZone Find Search control as SharePoint web part.
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How to configure ScanJour WorkZone Find Search Control
1. Activate the ScanJour WorkZone Find search control feature in the Site Collection Scope.
On the site web page, click Site Actions > Site Settings > Site Collection
Features.
2. On the Site Collection Features page, find ScanJour WorkZone Find Basic
Integration in the list. If it is not already active, then click Activate.
If you want to replace the standard SharePoint search box with the WorkZone
Find search box, activate the ScanJour WorkZone Find Integrated Search
Box feature.
3. Under Site settings, set up WorkZone Find connection. Specify the following settings in the WorkZone Find integration group:
1. WorkZone Find Connection
In the Service Path field, type the WorkZone Find Web Search
Page Type Ahead service address:
http://[Server]:[Port]/[SearchApplication]/AtlasService.asmx
Example:
http://iboxserver:80/Search/AtlasService.asmx
Note: The WorkZone Find Search Web Page must be installed on
WorkZone Find Server.
2. WorkZone Find Search URL
In the Redirect Path field, type the URL of the WorkZone Find Web
Search:
http://[Server]:[Port]/[SearchApplication]
/search.aspx
Example:
http://iboxserver:80/Search/search.aspx
Click Save changes.
4. To add the ScanJour WorkZone Find Search control WebPart to a page, on the
Page tab, click Edit to view the WebPart page in Edit mode.
Note: Ensure that you are running with SharePoint administrator privileges.
5. On the page, click Insert > WebPart.
6. Under Categories, select ScanJour.
7. Under WebParts, select the ScanJourSearch WebPart.
8. Click Add.
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9. The ScanJour WorkZone Find search control will be displayed in the webpage with
the Type Ahead feature enabled.

Note: On the client machine, enable the Access data sources domains setting in
the Security settings of your browser to make the Type Ahead feature function
correctly.
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Working with WorkZone Find Connector Manager
Working with WorkZone Find connector settings demands strong technical skills and thorough
knowledge of the operational features of WorkZone Find software and specifically the connector
functionality. Configuration of WorkZone Find connectors should be done by ScanJour
professional services.
UNIFIED CONNECTOR FRAMEWORK (UCF)

Unified Connector Framework (UCF) is a shared module for all the WorkZone Find connectors.
This module includes all common functionality needed by the connectors. The user interface is
called the WorkZone Find Connector Manager.
WORKZONE FIND CONNECTOR MANAGER

WorkZone Find Connector Manager is a tool for configuring connectors based on UCF.
WORKZONE FIND CONNECTORS

WorkZone Find NTFS Connector, WorkZone Find SharePoint Connector, EASY ENTERPRISE.x
Connector, and ScanJour ECM Connector are parts of WorkZone Find Unified Connector
Framework (UCF). These connectors scan the repositories, thereby creating iBlocks for each
information item in the scan scope. In the following introduction to these connectors, the usage
of the different settings and configurations of connectors in WorkZone Find Connector Manager
is described.
WorkZone Find NTFS Connector
WorkZone Find NTFS Connector keeps track of all files and folders on the file shares within
the NTFS repository which have been included in the WorkZone Find scan scope and creates
subsequent iBlocks in WorkZone Find. It ensures that modified, moved, copied, and deleted
items are always reflected correctly with their corresponding tags in WorkZone Find. It is
possible to scan multiple file shares.
WorkZone Find SharePoint Connector
WorkZone Find SharePoint Connector keeps track of all files, folders, SharePoint list items,
lists, document libraries and sites within the MOSS 2007 or SharePoint 2010 repository and
creates subsequent iBlocks in WorkZone Find. It ensures that modified, moved and deleted
items are always reflected correctly with their corresponding tags in WorkZone Find.
WorkZone Find SharePoint Connector supports scanning of multiple SharePoint servers.
Note: All SharePoint servers must run the same version of SharePoint (MOSS 2007 or
SharePoint 2010).
WorkZone Find ScanJour ECM Connector
The purpose of ScanJour ECM Connector is to scan information items from ScanJour ECM and
create subsequent iBlocks in WorkZone Find. It is capable of scanning cases, documents, and
contacts from ScanJour databases.
It uses SOM API to access the ScanJour ECM data. ScanJour ECM Connector supports the
following ScanJour products Version G, Captia versions 3.0, 4.x, and WorkZone Content
Server 2013. It supports scanning of multiple ScanJour ECM servers, but the same ScanJour
ECM version must be installed on all the servers if they are to be included in the WorkZone
Find scan scope.
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WorkZone Find EASY ENTERPRISE.x Connector
The purpose of EASY ENTERPRISE.x Connector is to scan information items from EASY
ENTERPRISE.x archives and create subsequent iBlocks in WorkZone Find. It is capable of
scanning documents and attachments from EASY ENTERPRISE.x archives.
EASY ENTERPRISE.x Connector supports EASY ENTERPRISE.x 3 and EASY ENTERPRISE.x 4.

WORKZONE FIND CONNECTOR MANAGER LAYOUT

The WorkZone Find Connector Manager layout comprises the following parts:

1. The Connector details area. It contains the list of installed connectors and the
description of the selected connector. It also contains the following buttons:
l

The
button – on click, the information about the status of the selected
connector is displayed. The connector can be in different stages such as: running, stopped, idle, and so on.

l

The Refresh button – on click, the connectors list is refreshed.

2. The Management pane. It contains a set of tabs available for all the connectors in
UCF.
3. Scheduler status – shows the next scheduled scan if scheduling is enabled.
4. In the Debug mode view pane, the information regarding the connector activities is
displayed.
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5. The Configuration pane. Contains the drop-down list from which you can select
the required configuration mode:
l

Engine – the settings of the configuration mode are generic and are primarily configured during the initial scanning phase. They include Enable
Resume Points and Force full rescan (see theTypes of scan section for
more details).

l

Information provider – the settings of the configuration mode depend
on the selected connector. The Information Provider Settings include
enabling/disabling Event handler, configuring Freetext file extensions for scanning, free text extraction, and so on.

l

Scheduler.

The working area of the Configuration pane changes according to the selected
configuration mode.
TYPES OF SCAN

As an WorkZone Find administrator you can set the scan scope and configure additional settings
which can be set individually for each of the connectors in UCF Manager.
For WorkZone Find NTFS Connector, the Scope tab will have all the child folders of the root and
it is possible to include/exclude folders.
Important: Any file, which has a path longer than 260 characters, including the server name,
will not be scanned. An exception will be logged in WorkZone Find Index Manager.
How to specify the scan location
1. Click the required connector in the list of connectors displayed in the Connectors
pane.
2. Click Scan scope in the Configuration pane. The Scan scope configuration
window is displayed.
3. Set the locations to be scanned. You can expand a Web application level to Site
collections, to Sites and to Lists and Document libraries.
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4. Set the child level locations to be scanned.
How to extract new properties
You can extract new properties as they are created in the repository. For example, when a new
column is added in the SharePoint document library, the properties can be extracted
automatically. To do this, select the Extract new properties by default check box in the
Scan scope configuration window.
How to specify the properties
You can specify the properties to be extracted and the properties to be included in freetext. To
do this, click the Content tab in the Scan scope configuration window.
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Select the properties to be extracted and, if required, to be included as freetext.
SCAN STATISTICS

WorkZone Find provides enhanced statistics regarding scans and errors.
The Management section of WorkZone Find Connector Manager contains tabs with a
different set of statistics.
The Summary tab provides details about the scan start and scan stop times along with the total
scan time. It also contains the details regarding the scanned items (for example, the number of
files, folders, and so on), as well as the number of errors which occurred during scanning (if
there are any). The detailed error messages can be viewed from the Error tab.
The error statistics provides the detailed information regarding the errors encountered during
the scanning process, that is, errors encountered by the Event handler, and so on. This
facilitates effective debugging.
If the Event handler is enabled, the statistics will include the details about the number of new
items added, number of items modified, and so on.
The Advanced tab provides technical details about the connector activities for debugging
purpose.
EVENT HANDLING

The WorkZone Find connectors listen to the source repositories. If the trigger is activated, the
corresponding event occurs.
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An information item in the NTFS repository is moved from one folder to another. When the item is
moved, the WorkZone Find connectors activate a trigger that updates the corresponding iBlock with
the new location and tags.
Create, Copy, Delete, Move, Rename, and Update are the typical events that occur in the
repository, and the WorkZone Find connectors handle these events appropriately. The connectors
can be configured to enable/disable event handling through a setting called Enable Event Handler
in the Engine configuration mode.
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Working with WorkZone Find Index Manager
WorkZone Find Index Manager is an administrative tool for performing the main operations in
WorkZone Find. The performance of WorkZone Find can be compromised if WorkZone Find
Index Manager is incorrectly configured.
INTERFACE OVERVIEW

When you start WorkZone Find Index Manager, the main window is displayed. It contains the
following elements:
1. Main menu – you can use the main menu to perform configuration and debugging
operations.
2. Tabs – each tab provides info about specific states of WorkZone Find.
Note: The information in most of the tabs described below is highly technical and is
used mainly for debugging purpose only.
Tab

Log

Error

Description

This tab contains info on all the events and
processes which are running at the moment
on the WorkZone Find server. For example:
l

settings change,

l

search running,

l

search index update,

l

text index update,

l

connection status.

This tab contains all error messages that are
thrown by WorkZone Find index.

Summary

This tab contains core summary of the
iBlocks. Typically, the summary contains the
following data: the number of iBlocks, the
number of users and groups, memory size,
disk capacity and so on.

Jobs

This tab contains the list of active jobs that
are being processed by the index.

iBlocks

On this tab the list of iBlocks that reside in the
WorkZone Find at any point of time is displayed. It is also possible to filter the list by
type, location, property, GUID, and ID. The
list of returned results can be sorted ascending or descending.

3. Working area – contains info which depends on the selected tab.
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CONFIGURING GENERAL SETTINGS

This section explains the most important settings that can be configured using WorkZone Find
Index Manager.
How to configure Index settings
This section describes the most frequently used settings for configuring the index.
On the File menu, select Index Settings. The IndexSettingsC window is displayed. Using this
window you can configure the settings described below.
IndexSettingsC Section settings
To configure these settings, select IndexSettingsC from the Section drop-down list.
AUTO TAGGING
l

AutoTagManuallyTagged - if this value is set to False, then during the auto tagging
process any information item (document, folder, SharePoint site, and so on) which
was manually tagged would be skipped. It means that WorkZone Find auto tagging
engine will not tag an item if it already contains a manual tag.

l

AutoTaggingInterval - the value of this setting defines the interval (in hours) for
running the auto tagging engine so that the automatic tags can be updated.

FILES AND FOLDERS
l

DataFolder - contains the path to the WorkZone Find index location on the disk.

LOGGING
l

LogLevel - the value of this setting predefines the level of details to be included into
the WorkZone Find log files. “0” – is the lowest level, while “2” is the highest (used for
debugging purpose).

MISC
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MinSystemDriveFreeSpace - by this value you can set the minimal amount of

l

free disk space in the WorkZone Find server for the WorkZone Find Index service
to perform to its potential.
SoftDeletedMaxAge - Any deleted item is marked as “softdeleted” in the cor-

l

responding iBlock.
By this value you can set the maximal time (in days) for retaining the softdeleted

l

iBlocks before they will be permanently removed from WorkZone Find.
AutoTermSettings Section settings
AutoTerm is a technique through which the new terms can be automatically populated into
WorkZone Find ModelBuilder.
SYNCHRONIZERSETTINGS

LogLevel - If the value of this setting is set to False, the autoterm rules in the

l

WorkZone Find ModelBuilder will not be processed. This means that the rule processing service will stop till this value is set to True.
LuceneTextIndexSettings section settings
WorkZone Find uses Lucene text search library for effective rendering the freetext. This
section describes the settings for configuring Lucene.
PLUG-IN
l

TurnOffLuceneDefaultOrBehaviour - If the value of this setting is set to True,
and if there is more than one word in the search string, the default operator will be
set to And (that is, the search will be performed by the complete phrase)

STOP WORDS

In this section, you can specify stop words that will not be taken in to account while
performing the freetext search. For example, if you specified the words “and”, “for”, and
“to” as stop words, they will not be included into the search results.
TEXT INDEX
l

AutoUpdate - If the value of this setting is set to True, the text index will be automatically updated.

l

AutoUpdateInterval - This setting is used to specify the time interval (in seconds) for automatic updating of the text index.

SAVING THE COMPLETE INDEX

One of the features of WorkZone Find Index Manager is the ability to back up the existing index
so that it can be reused later.
How to save the index
1. Click File > Save Complete Index.
2. In the Save Complete Index dialog box, specify the location path of the file and
click Save.
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RESETTING THE INDEX

You can delete all data from the index, including the information model, by resetting the index.
Resetting the index can also be useful when you upgrade the WorkZone Find and want to delete the
existing model and create a new model.
Important: When you reset the index, all the manually added tags will be permanently lost.
How to reset the index
1. Stop all services related to WorkZone Find.
2. Start the WorkZone Find Index service.
3. Open WorkZone Find Index Manager and click File > Reset.

LOADING THE INDEX

In case of file upgrade or recovery, you can load and use the index from the previously saved file.
How to load the index
1. Click Control Panel > Administrative Tools> Services. In the Services window, stop all the WorkZone Find services including the WorkZone Find Index service. After this, start only the WorkZone Find Index service.
2. Open WorkZone Find Index Manager. Click File > Load Complete Index.
3. From the Load Complete Index dialog box, navigate to the location of the file that
you want to load and click Open.

MANAGING THE SEARCH INDEX

The search index contains the look up list to support WorkZone Find search interface. This section
describes the main configurations that you can set in WorkZone Find Index Manager.
How to create the default search index location
When WorkZone Find is installed for the first time, you need to specify the default location of the
search index.
Note: Before you can specify the default search index location, you have to scan at least one of
the repositories.
To set the default search index location,
1. Open WorkZone Find Index Manager.
2. Click Search Index > Create default search index location.
How to rebuild the search index
It is a good practice to rebuild the search index in case of recovery or as part of upgrade.
To rebuild the search index, perform the following procedure:
1. Click Search Index > Rebuild.
2. The search index will be rebuilt and the corresponding records will be added to the
log.
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MANAGING THE TEXT INDEX

The text index contains the text that is extracted from the information items (folders,
documents, SharePoint items, and so on) while scanning. This section describes the main
configurations of the text index which can be set using WorkZone Find Index Manager.
How to update the text index
After performing a full rescan or after changing the Lucene settings you may need to update
the text index.
To force an update of the text index, click Text Index > Update.
PERFORMING AUTO TAGGING

To perform auto tagging, Click Tools > Auto tag. Based on the auto tagging rules that have
been created (see the section Working with Automatic Tagging in the Metadata Management &
Tagging Guide).
How to remove all automated tags
To remove all the automatic tags created by WorkZone Find auto tagging engine, perform the
following steps:
1. Click Tools > Remove all automatic tags.
2. All the automatic tags will be removed. This means that all automatic tags will
become unsearchable till the auto tagging process is started again.
How to remove old softdeleted iBlocks
To remove old soft deleted iBlocks manually, click Tools > Remove old softdeleted
iblocks. This operation overrides the SoftDeletedMaxAge setting.
Note: The SoftDeletedMaxAge value is set to 1 by default. It means that all the soft
deleted items will be permanently removed after 1 day.
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Troubleshooting
Issue:
The details (location, tags) for some information items (document, folder, and so on) are not
displayed in a browser when you click on the iBlock from the search results.
Reason:
Your iBlock may contain too many tags and the default web server configuration does not allow
processing this information and passing it to your browser.
Solution
1. Open web.config file. It is located on:
C:\Program files\ScanJour\WorkZone Find\Web Server Components\Web
Search
2. Add or modify the following lines:
<system.web.extensions>
<scripting>
<webServices>
<jsonSerialization maxJsonLength="512000" />
</webServices>
</scripting>
</system.web.extensions>
3. Try setting a higher value for the maxJsonLength parameter as shown in the snippet
above.
Issue:
Summary of every information item (document, folder, and so on) is displayed in the WorkZone
Find search page even though the SummaryLength index setting is set to 0.
Reason:
An engine setting called Summary Property Maximum Length is available to all connectors
and it is set, per default, to extract the first 256 characters from the information item.
Solution
1. Open WorkZone Find Connector Manager.
2. Select the connector in the left pane.
3. Select Engine from the Configuration drop-down list.
4. Set the value of the Summary Property Maximum Length property to 0.
5. Perform a full rescan.
Issue:
Auto tagging does not seem to work when the files are already tagged manually or through
another auto tagging rule or autoterm rule.
Reason:
By default, WorkZone Find is set to not tag items if they are already tagged.
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Solution
1. Open WorkZone Find Index Manager.
2. Click File > Index Settings.
3. In the IndexSettingsC window, leave the IndexsettingsC item selected by
default from the drop-down list.
4. Set the value of the AutoTaggedManuallyTagged setting to True.
5. Save the settings.
6. Click Tools > Auto tag in WorkZone Find Index Manager to run auto tagging.
Issue:
The error with listed below parameters occurs while working with WorkZone Find Web Search
page:
Error message: String cannot be of zero length. Parameter name: name
Target method: Void.ctor(SystemString)
Source: mscorlib
Solution
To fix this issue, perform the following steps:
1. Uninstall WorkZone Find.
2. Click Control Panel > System and Security > Administrative Tools >
Internet Information Services (IIS) Manager.
3. In Server Management window, select the Search web site.
4. In the IIS section, double-click Authentication.
5. Make sure, that all the methods except Windows Authentication are disabled.
Issue:
When the name of the parent item in SharePoint 2007 or SharePoint 2010 storage is changed,
the URNs of its child items remain the same. Therefore, the path to the child item won’t be
correct.
Solution
To fix this issue, perform the incremental scan of the SharePoint storage.
Issue:
While scanning, custom property types are added to WorkZone Find Index. If the items are
removed from the repository, the corresponding property types still remain in WorkZone Find
Index.
Solution
To remove such orphan property types, perform the following steps:
1. Click Program files > ScanJour> WorkZone Find> Miscellaneous > iBox
Console.
2. Start iBoxN.exe.
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3. Open WorkZone Find Index Manager and click the Property Types tab. Find the
property you want to remove and copy its UID.
4. In the console window, type the following: propertytype remove uid=n,
where n is UID of the property type you want to remove. Press Enter. The property
type will be removed.
Issue:
While clearing the text index using the clear/close/open/update items in the menu of the
WorkZone Find Index Manger, it will result in a job that will run for many days. The reason for this
is, that the update of the text index is done by traversing all generations from generation 0 (When
WorkZone Find is installed it starts with generation 0, and every time a block have been modified,
removed or created a new generation is created).
Solution
If you want to add a new property to the text index, you have to configure this, and then perform
a force full rescan of all repositories which will populate the new property. This will result in the
text index being updated with events from the current generation – and not with events from
generation 0.
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Resolving Captia Data Issues
ScanJour ECM Connector uses SOM to read data in the ScanJour database, and all data in the
database should therefore be readable by SOM. The problem is that not all data in a ScanJour
database has been created by SOM.
This data exists if:
l

The database is not created in the current version but has been upgraded in current version.

l

There are database level integrations that populate or update data in the database.

l

There are other integrations or add-ons that bypass SOM.

l

The Active Directory contains invalid data that is replicated to the ScanJour Database.

When the connector is doing a full scan, it uses a buffer that is filled with items using SOM. The
size of the buffer is specified in a connector setting – by default it is 10000.
If SOM throws an exception when it is filling the buffer, the whole buffer will be lost. This could
mean that a data error in one fileclass (Danish: “sagsgruppe”) can result in 10000 fileclasses
being lost, together with all casefiles (Danish: “sag”) attached to the fileclasses and the
documents attached to these casefiles.
Therefore, it is important to notice if there are any exceptions during the scan, and to be aware
that one single exception could mean that 100000’s of documents have not been scanned.
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Known Data Issues
The following data problems have been seen in the test environments where ScanJour ECM
Connector has been tested. ScanJour recommends that you test for the known problems before
you start the scan – otherwise you can easily get a “Sammensat nøgle er ikke unique (type,kode)”
(English: “Compound key is not unique (type,code)”)-exception during the scan.
POSTAL CODE IS NOT EMPTY, BUT COUNTRY CODE IS EMPTY

This problem exists if the SQL query below returns a number greater that zero.
SQL for Captia 3 and version G
SELECT COUNT(*)
FROM navneadresse
WHERE postnr IS NOT NULL and landkode IS NULL;
SQL for Captia 4.2 and 4.5
SELECT COUNT(*)
FROM name_address
WHERE postcode IS NOT NULL and country_code IS NULL;
When solving this problem, you should be aware that it could be AD Connector that produces the
empty country code. This can occur, for example, if AD Connector copies the country code from
Active Directory, and some employees have an empty country code in the AD. If you do not solve
the problem in AD, the erroneous data will reappear the next time AD Connector runs.
RECORD TYPE IS EMPTY OR CONTAINS SPACE CHARACTER

Issue: record type is a required field, and SOM throws an exception if it is not filled out.
This problem exists if the SQL query below returns a number greater that zero (notice the space
characters between the quotes):
SQL for version G and Captia 3.0
SELECT COUNT(*)
FROM akt
WHERE akttype IS NULL or akttype = ‘ ‘;
SQL for Captia 4.2 and 4.5
SELECT COUNT(*)
FROM record
WHERE record_type IS NULL or record_type = ‘ ‘;
FILE TYPE CONTAINS SPACE CHARACTER

Issue: Filetype is not a required field, but if the field contains a space character, SOM will throw an
exception when trying to get the elaborating text for the Filetype field.
This problem exists if the SQL query below returns a number greater that zero (notice the space
characters between the quotes):
SQL for version G and Captia 3.0
SELECT COUNT(*)
FROM sag
WHERE sagstype = ‘ ‘;
SQL for Captia 4.2 and 4.5
SELECT COUNT(*)
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FROM “FILE”
WHERE file_type = ‘ ‘;
EXCEPTIONS DURING SCAN

The exceptions that are thrown by the connector are shown in the user interface of WorkZone
Find Connector Manager and can be found in the log file:
C:\Program data\iBox\Log\iBoxSJConnector.exe_error.txt
If the exception is thrown while filling the buffer, it contains the ScanJour register name and
system key of the item that caused the exception.
Example
Exception has been thrown by the target of an invocation. Register:akt;
Systemkey:3010008;
System.Reflection.TargetInvocationException
Exception has been thrown by the target of an invocation.
System.Runtime.InteropServices.COMException
Sammensat nøgle er ikke unique (type,kode)
at ScanJour.SOM.LateBinding.sjTemplate.Merge(Int32 number)
at
ScanJour.iBox.Ucf.ScanJourInformationProvider.RegisterStore.getSubRegisterItems(String
fatherKey, String systemKey)
at
ScanJour.iBox.Ucf.ScanJourInformationProvider.DataItemStore.GetRegisterItemsUnderItem(String
database, String sjregister, String systemKey, String parentSystemKey)
at ScanJour.iBox.Ucf.ScanJourInformationProvider.ScanJourItem.FirstChild
()
at
ScanJour.iBox.Ucf.Engine.ProviderEntryPoint.CrawlItemEntryPoint.<FirstChild>b__c()
at ScanJour.iBox.Ucf.Engine.Invoker.InvokeMethod(GenericDelegate d,
String actionName)
at
ScanJour.iBox.Ucf.Engine.ProviderEntryPoint.CrawlItemEntryPoint.FirstChild()
at ScanJour.iBox.Ucf.Engine.InformationProviderWorker.IterateContainer
(ICrawlItem crawlItem, UInt32 locationID, ResumePoint parentPath)
at System.RuntimeType.InvokeDispMethod(String name, BindingFlags
invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32
culture, String[] namedParameters)
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at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags,
Binder binder, Object target, Object[] providedArgs, ParameterModifier[]
modifiers, CultureInfo culture, String[] namedParams)
at System.Type.InvokeMember(String name, BindingFlags invokeAttr, Binder
binder, Object target, Object[] args)
at ScanJour.SOM.LateBinding.sjTemplate.Merge(Int32 number)
The exception contains a lot of information, but the three important parts are the name of the
register (akt), the system key (3010008) and the message in the COMException (“Sammensat
nøgle er ikke unique”) which is the description of the error received from SOM.
With this information you should be able to find out what the data problem is and correct it.
Solution
The first thing you should do is to find the problematic item through the user interface of Captia,
and see if it can be displayed in Captia.
If it can be displayed, the problem is probably caused by the properties that are merged on the
object.
Use SOM ASP to find exact property. If you make a SOM ASP query it finds the item like this one:
http://mak/scanlog/search.asp?register=akt&aktlbnr=3010008&templatestring=@
[sagstype#elab]@
You can try to insert the mergehandler codes for the properties that are selected on the register
(Danish: “akt”) into the URL parameter “mergehandlerstring”. You can find the merge handler
strings for the different properties through WorkZone Find Connector Manager, in the
ScanJourBlockSettingArray/PropertySettings for the block type.
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Terms and conditions
INTELLECTUAL PROPERTY RIGHTS

This document is the property of ScanJour. The data contained herein, in whole or in part, may
not be duplicated, used or disclosed outside the recipient for any purpose other than to conduct
business and technical evaluation. This restriction does not limit the recipient’s right to use
information contained in the data if it is obtained from another source without restriction.
DISCLAIMER

This document is intended for informational purposes only. Any information herein is believed to
be reliable. However, ScanJour assumes no responsibility for the accuracy of the information.
ScanJour reserves the right to change the document and the products described without notice.
ScanJour and the authors disclaim any and all liabilities.
ScanJour is a trademark used under license by ScanJour A/S. All other logos, trademarks and
service marks are the property of the respective third parties.
Copyright © ScanJour A/S 2013. All rights reserved.
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