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Metadata Management and Tagging Guide for
WorkZone Find
PURPOSE

The purpose of this user manual is to:
l

Explain the core functionality of the metadata administration tool - WorkZone Find ModelBuilder.

l

Provide the descriptions of tagging the items with metadata terms both automatically and
manually.

TARGET AUDIENCE

The manual is primarily targeted at model administrators who build and maintain WorkZone Find
information models and super users or subject matter experts who use the WorkZone Find
metadata to create automatic tagging for automatic classification of the documents.
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Working with WorkZone Find ModelBuilder
This chapter explains how to use WorkZone Find ModelBuilder.
The Information Model
The information model is a comprehensive and multidimensional metadata model which can
hold the corporate taxonomies to effectively classify information items (for example,
documents and folders). It consists of:
l

Categories. The information model is a list of categories. A category is, for example,
an “Event” category holding the list of all the events held in the company.

l

Terms. Each category contains a list of different terms. A term is, for example,
“Dinner” under the “Event” category.

l

Synonyms and Relations. A term can have one or more synonyms, and a term from
one category can have a relation to a term in another category.
For example, a term “Dinner” (under the “Event” category) and a term “Room # 211”
(under the “Location” category) can be related.

WorkZone Find ModelBuilder
WorkZone Find ModelBuilder is the tool which enables you to create and administer the
information model (corporate taxonomies). It is a Windows-based application which is installed
on the WorkZone Find server and on the workstations of the information workers who are
responsible for managing the information model.

4

Metadata Management and Tagging Guide

Opening the Information Model
The information model is stored on the WorkZone Find server. WorkZone Find ModelBuilder is
used to retrieve the information model from the WorkZone Find server to view and edit it.
To open the information model, perform the following steps:
1. Open WorkZone Find ModelBuilder.
2. In the Locate Model Server dialog box, select one of the following options:
3. Access via a web service – select this option button and specify the location of
WorkZone Find server (Model Server): type the name of the computer which hosts the
WorkZone Find application.
Note: WorkZone Find ModelBuilder stores the names of the last 10 WorkZone Find servers to
which it has successfully connected. They are listed in the drop-down list.
4. Direct access – select this option button if WorkZone Find ModelBuilder is installed
on the same computer as the WorkZone Find server. This will enable you to access the
information model directly, without involving Internet Information Server (IIS).
This option also has a slight performance advantage over accessing the information
model via a web service.
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Checking the Information Model Out and In
When you open an information model in WorkZone Find ModelBuilder, by default the
information model will be checked in and locked for editing. The
icon near the root category
shows that the information model is locked and you check it in or out. If the
icon is displayed,
it means that you have no rights to modify it.
In this case, log in either as a model administrator or a different user who has the Modify
rights. See section User rights.
CHECK OUT STATES

Each item in the information model can be in one of the six states. Each state has the
corresponding icon.

Icon

Description
The item is checked in and can be checked out by the current user.
The item is checked in and the current user does not have rights to check it out –
see also User rights .
The item is checked out by another user. The name of the user who checked the
item out is displayed on the status bar. See also How to undo the check out performed by other users.
The item is checked out by you (the currently logged on user). See also How to
impersonate a user.
The item is checked out by you (the currently logged on user), but from a different computer. See also How to undo the check out performed by other users.
The item has just been added and has not been checked in yet.

INFORMATION DISPLAYED IN THE STATUS BAR

The status bar contains five fields which display information about the state of the information
model or
selected item.
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Field

Description

1

The name of the user who is editing the model.
l

If this field is blank, the current user is unknown. In this case make sure
that the Active Directory (AD) Connector has been run at least once.

l

If the user name is enclosed in angular brackets (for example,
“<Admin>”), you are impersonating the user - see section How to impersonate a user.

2

The current state of the model. It shows whether the information model has been
edited or not. If blank, no changes have been made.

3

The state of the selected item.
l

Read Only – the user cannot edit the selected item. It is either not
checked out or the user is not authorized to modify the item.

l

Blank – the user may edit the selected item.

l

Owner – the user may edit the selected item and change its security settings (Rights).

4

If the selected item is checked out, the name of the user who has checked it out is
displayed in this field – or “Administrator” if you are logged in as such.

5

Contains the location of the WorkZone Find server from which the information
model was loaded.

How to check out the Information Model
To make changes to an existing information model, you must check out either:
l

the root category;

l

one or more categories;

l

one or more terms in the model.

Note: If you check out the root category of the information model, the entire information model
will be locked.
If you need to make changes only to a small part of the information model, check out only the
part you need to make changes to. This allows other model administrators to check out the other
parts of the information model.
To check out the model, perform the following steps:
1. Right-click the part of the information model that you want to work on, and select
Check Out.
Note: If you start with an empty information model, only the root category will be displayed in
the tree view. In this case, right-click the root category to check out the information model.
2. In the Check Out dialog box, select the check-out option:
l
l

Recursive – select this option to check out the selected items and all its child items.
Non Recursive – select this option to check out the selected items only.

How to undo a check out
To discard all the changes made to the model, perform the following steps:

7

WorkZone Find 2013

1. Right-click the previously checked out item of the information model in the model
tree.
2. Select Undo Check Out.
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Working as Model Administrator
When you are logged on as the model administrator, you can:
l

Check out and edit items even without Modify rights.

l

Undo checkout of the items which are checked out by other users.

To log on as Model Administrator, click Tools > Security > Login as Administrator.
The password is blank by default. If you have changed the password and want to revert it to blank
again, on the server side run iBoxMigrate.exe with these switches: /modelserver /clearadminpsw.
It is located on C:\Program Files\ScanJour\WorkZone Find\Miscellaneous\IBoxUtil.
How to undo the check out performed by other users
To undo the checkout performed by other users, log on as the Model Administrator or specify the
Model Administrator password when asked.
Perform the following steps:
1. Click Check In/Out > Check Out Overview. The Check Out Overview dialog
box is displayed. It contains the following information:
l

User name – the name of the user who performed the checkout.

l

Computer name – the name of the computer from which the checkout was performed.

l

Item count – the number of the items which were checked out.

l

Latest check out – date and time when the items were checked out for the last time.

2. To undo any of these checkouts, select the corresponding record in the list and click
Undo Check out.
How to impersonate a user
When working with model administration rights, it is useful to see the information model as if
you were a different user. This is called impersonating a user.
To impersonate a user, perform the following steps:
1. Log in as the Model Administrator.
Optional: Click Tools and enable Edit Security when Impersonating. This will
allow you to change security settings even when you are impersonating a user who
does not have the Owner rights.
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2. Click Tools > Security > Login As.
3. Select the user you want to impersonate and click OK.
How to disable change management
When you are logged in as the Model Administrator and you are the only user working with
the information model, you may choose to disable change management.
This will allow you to edit the entire model and save the changes without having to check out
and check in.
Note: If you reload the information model, you will have to select Disable Change
Management again.
Perform the following steps:
1. Log in as Model Administrator.
2. Click Tools and select the Disable Change Management check box.
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Managing categories in the Information Model
The order of the categories can be changed by drag and drop function.
To change the order of the categories, do one of the following:
l

Check out the root category and move the category to the required location in the information model;

l

Check out the category as well as all categories between the original and the final positions of the category that you are moving. After this, move the category.

When you have built your information model, back up it. This can be done by the Microsoft Excel
export/import function.
Important: However, when exporting the metadata model to Microsoft Excel, the number of
characters in a category name cannot be greater than 31 because Microsoft Excel does not accept a
tab name greater than 31 characters – see sectionBacking Up the Information Model Using
Microsoft Excel.
You can also save the model to a .dat file. This file will also back-up the autoterm rule and
category icons – see section Backing up the Information Model Using a DAT File.
How to add a category
1. Check out the root category (and all other categories below the point at which you
want to add the new category).
2. Select a place in the tree, where you want to add the new category.
Note: If you select the root category, or if one or more of the categories below the selected
category are not checked out, then new category will be inserted as the last category in the tree.
3. To add a new category to the information model, perform one of the following:
- Right-click the root category and select Add Category.
- Click the Add Category icon in the WorkZone Find ModelBuilder taskbar.
- Click Insert > Add Category.
- Press <Ctrl+D>.
4. A new category will appear in the model tree with a unique default name, for
example, “New Category”. You can rename it.
How to add an icon to a category
When the new categories are created, they are assigned the default WorkZone Find icon
You can assign a different icon to the category. To do this, perform the following steps:

.

1. Double-click the category.
2. In the Category Details dialog box, on the General tab click Enabled icon.
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3. From the Browse for Enabled Icon dialog box, navigate to the location of the
required icon and click Open. Icon size must be 16x16 px.
4. When you select a new icon, WorkZone Find ModelBuilder will automatically generate a disabled version of the icon (used when displaying the non-taggable
terms in iBox Tagging Client). To change the disabled icon, click Disabled icon.
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Adding synonyms to terms
You can add one or more synonyms to a term.
Synonyms are words with the exact or similar meaning. For example, you can add an alias as a
synonym to a name. When an item is tagged with a term that has a synonym, then both the term
and the synonym are added as tags.
When you perform a search using a metadata term which has a synonym, you will get results for
both: the term and the synonym.
How to add a synonym
1. Double-click the term to which you want to add a synonym. For example, the term
“Denmark” under the category “Geography”.
2. In the Term Details window, click the Synonyms tab.
3. Click Add and type the name of a synonym, for example, “DK”.
Click Add to add more synonyms for the term in question, if required.

4. Click Close.
5. Click the category to which the term belongs. Verify that the synonym “DK” is displayed.
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You can check added synonym using WorkZone Find.
Example
In the procedure described below, the synonym “DK” is used as an example.
To verify the synonym in WorkZone Find, perform the following steps:
1. Open WorkZone Find search page.
2. Type “DK”. “DK” is identified as a synonym for the term “Denmark”. Therefore,
the term “Denmark” is displayed below the search field with the synonym in
brackets as shown below:

3. Select the “Denmark (DK)” search term and click Search.
4. Check that WorkZone Find finds the Microsoft Word document previously tagged
with the term “Denmark”.
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Adding terms to a category
The Add Term button (you can use the <Insert> key) adds a new term at the same level as the
selected term (or a new top level term if a category is selected).
The Add Child Term button (you can press the <Ctrl+Insert> keys) adds a new term as a child
of the selected term.
In all cases, adding a term is only possible if the parent of the new term is checked out.
How to add a term
1. Check out the category to which you want to add a term.
2. Select the category and click Add Term.
3. A new term is created with a unique default name. The new term is open for renaming. Enter a term name (press <Esc> to accept the default name).
Note: By default, the terms are ordered alphabetically. When you rename them, their position
can change.
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Managing relations
You can create relations between items in the information model. First, you need to define the
relational type, for example, a relation type named Lives In between a category named
“Author” and a category named “Geography”.
Second, you need to relate the two terms using the relation Lives In. For example, “Line
Hansen” and “Denmark”.
Relation types are used to define relations between terms. The relation type specifies that
terms in Category A can be related to (linked to) terms in Category B. Category A and Category
B can be the same category or the root category.
For example, you can create a relation type named Lives In between a category named
“Author” and a category named “Geography”.
Example
1. Double-click the “Author” category.
2. In the Category Details dialog box, click the Relation Types tab.

Note: The list displays existing relation types. If you check Show Inherited, you will also see
the inherited relation types, for example, the relation types defined on the root category.
3. Click Add. Type the name of your new relation type Lives In.
4. Select the “Geography” category as the target one and click OK.
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Note: If you select the root category as the target category, you can make “Lives In” relations
from any term in the “Author” category to any other term in the information model, regardless
of the category to which it belongs.
If you want the WorkZone Find users to see to which organizational entity a person belongs, add a
relation between the name of a person and an organizational entity. This can be useful if, for
example, there are more multiple persons with the same name in the system. Also, it enables
users to see which people belong to which organization unit.
Example
To add a relation to the organizational entity “Delivery” from the term Jane Doe (the name of a
person) who already belongs to the “Author” category, perform the following steps:
1. Double-click the term, for example, “Jane Doe”, to which you want to add a relation.
2. In the Term Details dialog box, click the Relations tab.
3. Click Add.
4. In the Term Relation Editor dialog box, select the required item from the Relation Type drop-down list
5. Select the term in the Target Term section, for example, “Delivery”.
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6. Click OK.
Note: Click Add to add more relations, if required.
7. Double-click the term, for example, “Jane Doe”, to verify that a relation has been
added – in this example to the “Delivery” term. In the Term Details dialog box,
click the Relations tab and check the relations.
Note: Whenever a document is tagged with the main term, for example, “Jane Doe”, the
document is automatically tagged with the related term, for example, “Delivery”.
8. Click Close.
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Tagging options
WorkZone Find ModelBuilder provides various options which can be set for individual terms to
define the behaviour of a term in the iBox Web Based Tagging Client. These options include:
l

Taggable: You can make a term available for tagging, or you can disable it, if it is a grouping term that should not be used for tagging.
In the information model tree, the

icon in front of a term shows that the term is tag-

gable.
The
l

icon shows that it is not taggable.

Suggest Term: If the term exists in the item you are tagging (for example, file, folder
name or site name), it is suggested as a tag by iBox Web Based Tagging Client.

l

Auto Tagging: You can enable the term for automatic tagging – see section Working with
automatic tagging.

You can also set the above options for all child terms of a given term.
How to make a term not taggable
By default, a term is taggable. It means that you can apply the term to a file or a folder from
iBox Web Based Tagging Client. However, some terms in the information model may be very
generic and used just for grouping lower level terms, and should therefore not be available for
tagging. To achieve this, the term must be not taggable.
For example, if an employee has left the company, you may want to make the term not
taggable.
To make the term not taggable, perform the following steps:
1. Double-click the term which you want to edit.
2. In the Term Details dialog box on the General tab under Tagging options, clear
the Taggable check box (it is selected by default).
How to make a term taggable
To make the term taggable, perform the following steps:
1. Double-click the term which you want to edit.
2. In the Term Details dialog box on the General tab under Tagging options, select
the Taggable check box.
How to test tagging options
You can verify that your settings have been applied. Remember to save your changes in
WorkZone Find ModelBuilder first. If the AutoUpdateSeachindex setting is set to False in
WorkZone Find Index Manager, you must rebuild the index. To rebuild the index, in WorkZone
Find Index Manager, click Seach Index > Rebulid.
To test the tagging options which you have configured, perform the following steps:
Note: In the procedure described below, the terms “Jane Doe” and “John Smith” are used as an
example for testing the tagging options.
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1. Open WorkZone Find ModelBuilder and click File > Save.
2. Open a new MS Word document.
3. Type some terms already available in the information model, for example, “Jane
Doe” and “John Smith”.
4. Save the document to an WorkZone Find enabled path of the server.
5. Verify the following settings in Web Based Tagging Client:
l

The term “John Smith” is set as Not taggable and is greyed out in Web Based Tagging Client.

l
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The term “Jane Doe” is set as Taggable in Web Based Tagging Client.
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Saving changes to the Information Model
You can save your changes in two ways:
l

Save a part of the model, for example, a category or a term. To do this, right-click the
item and select Check In.

l

Save the entire model. To do this, click the Save icon.

After you have saved the changes, you can choose to check in the changes, or to leave the
information model checked out if you wish to keep working on it.
How to save separate items
If you wish to save only the terms and categories which have been updated, use the check in
function.
Perform the following steps:
1. Right-click the item in the information model you wish to check in and select Check
In.
2. In the Check In dialog box, choose the check in option of your choice:
l

Recursive: Check in the selected items and all child items.

l

Non Recursive: Check in only the selected items.

3. Click OK.
4. The Check In dialog box is displayed if there are any changes.
The icon near the selected item is changed to

. It means the Information Model is

checked in.
The model has no pending changes. The Modified status in the status bar disappears.
Note: Whenever changes are saved, WorkZone Find ModelBuilder synchronises the information
model with the server, for example, any changes made by other users will be reflected in
WorkZone Find ModelBuilder.
How to save the entire model
To save changes which you have made to the Information Model, perform the following steps:
1. Click Save.
The Check In dialog box is displayed:
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Summary
The window contains a summary of all changes made to the model.
Comments
Enter a comment if needed. Comments are displayed in the change history.
Keep checked out
If you select the Keep checked out check box, your changes will be saved but
the items that you have checked out will remain checked out so that you can continue working on them.
Show change history
If you select the Show change history check box, the Change History window
will display after your changes have been saved. The window will contain all the
changes that have been made to the information model since the last time WorkZone Find ModelBuilder was synchronised with the server.
2. Click OK to save the changes.
3. If you selected the Show change history check box, the change history is displayed.
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Backing up the Information Model manually
You can back up your information model manually. ScanJour recommends you to do this at least in
these two situations:
l

Before and after you make major changes to the information model.

l

Before you upgrade to a new WorkZone Find version.

You can manually create the information model backup:
l

Using an .xls file – for example, in the first phase of an WorkZone Find implementation
project to build up the information model in WorkZone Find ModelBuilder. See section 2.13
Backing Up the Information Model Using Excel.

l

Using a .DAT file – for example, during project implementation after the icons have been
added. See section 2.14 Backup the Information Model Using a DAT File.

Note: After you have created an information model, ScanJour recommends that you back up the
information model by using the automatic and scheduled backup through the WorkZone Find
Command Line Interface.
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Backing Up the Information Model Using Microsoft Excel
The export/import functionality of Microsoft Excel is primarily used in the first phase of an
WorkZone Find implementation project to build up the information model in WorkZone Find
ModelBuilder.
Note that the Microsoft Excel functionality Export to Excel/Import from Excel has the following
peculiarities:
l

It does not save icons or the unique ID of each term.

l

It does not accept the length of a category name that exceeds 31 letters (because Microsoft Excel does not accept a tab name greater than 31 characters).

l

It only accepts Microsoft Office 2003 format (.xls format) – but not .xlsx or other formats.

Note: If you use Microsoft Office 2007 or 2010, you must save the backup files in Microsoft
Office 2003 format (.xls).
How to export the Information Model to Microsoft Excel
Follow the procedure below to create a Microsoft Excel backup of your information model.
Open WorkZone Find ModelBuilder.
1. Click Add-ins > Export to Excel.
2. In the Export Model window, select the categories in the information model that
you want to export.
To export the entire model, select either the Root Category or the Whole
Model check box.

3. Click Export.
4. In the message box, click OK.
5. Click Yes in the confirmation dialog box.
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6. In the Save As dialog box, specify the location for the model to be saved. Click
Save.
7. Click Close.
How to add data to the Information Model Using Microsoft Excel Import
The WorkZone Find ModelBuilder function Import from Excel can only be used to add data to the
information model. The Microsoft Excel version cannot be used to, for example, edit an existing
model structure or rename terms.
It is important to use a predefined style sheet when importing an information model from
Microsoft Excel into WorkZone Find ModelBuilder.
Note: If you want to move, delete, or rename the terms after they have been used for tagging,
you must do this directly in WorkZone Find ModelBuilder. Making such changes before importing
an information model from Microsoft Excel may result in term duplication and/or loss of tags.
You can import an information model only from .xls files (Microsoft Office 2003 format).
If you use Microsoft Office 2007 or 2010, you must save the backup files in Microsoft Office 2003
format, (.xls).
Open WorkZone Find ModelBuilder.
1. Open WorkZone Find ModelBuilder.
2. Check out the root category.
3. Click Add-Ins > Import from Excel.
4. In the Import Model dialog box, click Load.
5. In the Open window, browse to the information model folder.
Note: If you use Microsoft Office 2007 and the .xls files are not displayed, type “.” into the File
name field and press <Enter>.
6. Select the file to be imported. Click Open.
7. In the Import Model dialog box, select the Whole Model check box to import the
whole model, or select the part of it to be imported. If the selected categories are
not created yet, the import function will create them. Click Load.
8. In the Administrator Login dialog box, enter the password. Click OK.
9. Click OK in the notification dialog box.
10. Validate that the information model or its part was loaded.
11. Save the information model.
How to import terms with relations
Before you import a category (source category) where the terms hold relations to terms in
another category, you first have to import the category (target category) you are relating to.
Otherwise, it may result in duplication of terms in the target category. For reference, see
section 2.8 Creating Relations.
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1. Open WorkZone Find ModelBuilder.
2. Create the categories of your choice as described in section 2.4 Adding Categories to the Information Model.
3. Export the information model into an Microsoft Excel sheet as described in section 2.13 Backing Up the Information Model Using Excel.
4. Save the Microsoft Excel sheet and open it.
5. Fill in the appropriate rows and columns with terms, synonyms, relations and
tagging options.

1. The name of the category (for example, Author) must be displayed in column A
row 1 and should be the same as the sheet name displayed on the Excel tab.
2. The first term (for example, “Jane Doe”) must start in column B row 6.
3. Synonyms must be added to a specific column (for example, “Synonym 1”).
You can create synonyms by adding new columns and naming them Synonym
2, Synonym 3, and so on.
4. Relations must be added in a specific column. You can create more relations by
adding new columns naming them Relation 2, Relation 3, and so on.
5. Define the tagging options for each individual term. In this example, “Jane
Doe” is not taggable whereas “John smith” is taggable.
How to use a predefined style sheet
It is important to use a predefined style sheet when importing an information model from
Microsoft Excel into WorkZone Find ModelBuilder. You can generate the predefined style
sheet by exporting a model from WorkZone Find ModelBuilder as described in section 2.13.2
Add Data to an Information Model Using Excel Import.
When importing an information model into WorkZone Find ModelBuilder via Microsoft Excel,
the prerequisites must be met.
Prerequisites list
Make sure that the spelling of the categories in the tabs and worksheet headings (cell A1)
are the same (both spelling and capitalisation).
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1. Make sure that the spelling of the categories in the tabs and worksheet headings
(cell A1) are the same (both spelling and capitalisation).
2. The first term must be added in cell 6B, the next term must be added in cell 7B,
third term in cell 8B, and so on.
3. Child terms must be added in the row beneath – not in the same row as - the “parent” term and in the column to the right (for example, a child to the term in cell 6B
has to be written in cell 7C, a child to the term in cell 7C has to be written in cell
8D, and so on).
4. Additional levels of child terms (3rd tier) can be added in subsequent columns.
5. The first “Synonym 1” starts in the column immediately after the last “Child term”.
The synonym must be placed in the same row as the term it refers to.
6. “Synonym 2, 3…” must be added in new adjacent columns in the same row as the
term it refers to.
7. All “Synonym 1” must be placed in the same column, different row. The same
applies for Synonym 2, 3…
8. The first “Relation 1” must be placed in the column following the last “Synonym”.
The relation must be placed in the same row as the term it refers to.
9. All “Relation 1” must be placed in the same column, different rows. The same rule
applies to “Relation 2”, “Relation 3”, and so on.
10. Make sure that you do not have empty rows between the terms.
11. All tagging options must be assigned Yes or No for each individual term.
Possible error messages and their reasons
If the information model does not follow the rules above when you try to import it, you will get
the following error message:
“There were errors during the import process. See log file for details.”
In case the format of the import model is insufficient and the above import error message is
displayed, a log will be created at the local machine from which the import took place.
The log file contains a complete overview of the formatting errors of the Microsoft Excel model.
The log file can be found in the following path:
C:\ProgramData\iBox\ModelBuilder\import
This log file explains in detail which category (tab) contains an error and in which specific row it
is located. For example:
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Backing up the Information Model Using a DAT File
Saving the information model to a .dat file is the only way to save all the different items of the
information model, including icons and GUIDs. You can restore your information model using this
DAT backup when needed.
How to save the Information Model as a DAT file
Perform the following steps:
1. Open WorkZone Find ModelBuilder.
2. Click Tools > Advanced > Save to file in the main menu.
3. From the Save As dialog box, select a location to save the information model.
In the field File name, type the name of the backup file.
4. Click Save.
How to enable the Save the file option
If the option Save to file is not displayed in the Tools menu, click Tools > Local iBox
Settings - see Advanced WorkZone Find settings.
In the iBox Settings Editor dialog box, set the Show Advanced Tab value to True, click
Apply and close the window. The Save to File menu item will be displayed.
ScanJour recommends that you use a .dat file (DAT backup) to create backup for the information
model on a regular basis and particularly before and after the extensive information model
changes.
How to restore the Information Model using a DAT backup
Perform the following steps:
1. Open WorkZone FindModelBuilder.
2. Click Tools > Advanced > Open from File.
3. From the Open dialog box, browse to the location of the previously saved backup
.dat file.
4. Select the file and click Open to load the information model.
5. If you want to load the information model to the server and apply your changes,
click Tools > Advanced > Save entire model to, select the server, and then
click OK.
How to enable the Open from file menu item
If the Open from file menu item is not displayed in the Tools menu, perform the following
steps:
1. Click Local iBox Settings.
2. In the iBox Settings Editor window, set the Show Advanced Tab value to
True.
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3. Click Apply.
4. Click Close.

You can also make changes to the information model when you are offline using a DAT file – see
Working Offline on the Information Model. Due to the uniqueness of the GUID’s it is now
possible to import the model to another environment.

30

Metadata Management and Tagging Guide

Working Offline on the Information Model
You can work offline on the information model and later load some or all of your changes to the
server.
To work offline on the information model and apply your changes when you are online again,
perform the following steps.
1. Open WorkZone Find ModelBuilder.
2. Check out the terms or categories you want to modify.
3. Click Tools > Advanced > Save to file.
4. From the Save As dialog box, select a location to save the information model. In the
File name field, type the name of the information model copy.
5. Click Save.
6. When you are offline, click Tools > Advanced > Open from File to load the model
to WorkZone Find ModelBuilder.
7. From the Open dialog box, browse to the location of the previously saved backup .dat
file.
8. Select the file and click Open to load the information model.
9. Make the changes to the information model and save the .dat file (see pt. 3-5 above).
10. When you are online and want to apply your changes, click Tools > Advanced >
Open from File.
11. From the Open dialog box, browse to the location of the previously saved backup .dat
file.
12. Select the file and click Open to load the information model.
13. Click Tools > Advanced > Save entire model to, select the server and click OK.
Your changes will be applied.
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Configuring advanced WorkZone Find ModelBuilder options
From this section you will learn how to customize WorkZone Find ModelBuilder.
How to customize WorkZone Find ModelBuilder messages
You can define the messages to be displayed when working with WorkZone Find
ModelBuilder.
Perform the following steps:
1. Open WorkZone Find ModelBuilder. Click Tools > Options.
2. In the Suppressed Messages section, clear check boxes for messages which
you do not want to receive.

3. In the Duplicate Term Checking section, you can select if WorkZone Find ModelBuilder should check for duplicates:
l

when you rename a term.

l

when you create or rename the synonyms.

ScanJour recommends leaving both check boxes selected.
Note: If the duplicate term checker is enabled and a term is added twice, but with different
capitalization, the terms will be regarded as duplicates.
How to view the history of changes
In WorkZone Find ModelBuilder you can view the history of changes made by the different
users.
Perform the following steps:
1. Open WorkZone Find ModelBuilder. To get latest changes on the history list, click
Check In/Out > Get Latest Changes.
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2. In the main menu, select Check In/Out > Show History.
3. In the Show History dialog box, select the required options. Click OK.
4. In the Change History dialog box, click Grouping and select the way in which the
log entries should be grouped, for example, Group by Date, Group by Date & Time,
Group by Category Name, and so on.
Click Sort and select the order for the log entries to be displayed. You can combine
each of these three options either in descending or ascending order.
5. To view the detailed information about the individual log items select a log entry and
select the Details check box. The detailed information on the selected log entry will
be displayed.
6. Click Close.
How to clear the history
To clear the history, click Check In/Out > Clear History. You need the Administrator rights
to perform this procedure.
How to synchronize the terms against backend systems
To retrieve the information from backend systems, synchronisation can be enabled for terms
and categories. This means that data contained in a customer list in the backend system can be
imported to WorkZone Find ModelBuilder using connectors.
How to enable synchronisation for terms and categories
1. Check out the model.
2. Right-click the category you want to enable for synchronisation and select Enable
synchronisation.
3. Verify that the category icon contains the synchronisation marker:
egory is now ready for synchronisation against backend systems.

. The cat-

When new terms are added to categories via synchronisation, you can set the security for the
new terms. By default, the security settings are inherited from the parent category.
How to set the specific security settings for a term
1. Check out the term.
2. Right-click the term and select Details.
3. In the Term Details dialog box, click the Rights tab. Set the rights as required.
4. Click Close.
5. Check in the term.
How to import the terms from the SharePoint 2010 term store
One of the most important features in SharePoint 2010 is Managed Metadata Service. This allows
the organisation to share metadata taxonomies and terms across multiple SharePoint webs and
site collections.
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SharePoint 2010 Managed metadata service is a hierarchical collection of centrally managed
terms to be used as attributes for items in Microsoft SharePoint Server 2010.
The WorkZone Find SharePoint 2010 integration enables the user to import and use
SharePoint metadata in the WorkZone Find components using an ODBC connection.
Before you start, you need to have the required permissions to perform this procedure.
Prerequisites
To view managed metadata service application properties, current user account must be:
l

A member of the Administrators group on the computer running the SharePoint Central Administration Web site.

l

A member of the Farm Administrators group.

The procedure below explains how to import the terms from the SharePoint 2010 term store
into WorkZone Find. The first step is to create a customised view in SharePoint Managed
Metadata database. This view will be used by WorkZone Find ODBC Connector to extract the
terms from the SharePoint 2010 term store.
After this, you have to create system ODBC sources which enables you to access SharePoint
Metadata Service Database as ODBC source.
How to create a customized view
1. Go to the SharePoint Central Administration web site.
2. Under Application Management, select Manage Service Applications.
3. Click in a column other than “Name” to select the Managed Metadata Service
row.
Note: If you click the name of the managed metadata service, the Term Store
Management Tool opens.
4. On the ribbon, click Properties.
5. In the Create New Managed Metadata Service dialog box, copy the Database Instance Name from Database Server string and Database Name that
hosts SharePoint managed Metadata Service – you will need this information
later.
6. Click Cancel.
7. You now have to create a customised WorkZone Find TermStore View in the
Managed metadata Service database on the SharePoint server.
Note: WorkZone Find SharePoint Add on must be installed.
8. Locate the WorkZone Find SharePoint Add On installation directory. The default
location is:
C:\Program Files\ScanJour\WorkZone Find\SharePoint Server Components\TermStore\
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9. From the command prompt, run the install.bat batch file with parameters for specific Database Instance Name on Local Machine and Database Name from step 5
above to create a customised view. Use this format:
install.bat [DataBaseInstanceName on Local machine] [DatabaseName]
Note: If there is a space in the database name, it has to be written in double quotes. For
example: “SP 2010 managed metadata DB”. This operation should be performed on the
database server, locally.
How to configure ODBC data source
To create system ODBC sources which enables you to access SharePoint Metadata Service
Database as ODBC source, perform the following steps:
1. On the WorkZone Find server, use the odbcad32.exe Windows tool. It is located on:
l

C:\windows\syswow64\odbcad32.exe – for 64 bit operating systems;

l

C:\windows\system32\odbcad32.exe – for 32 bit operating systems.

3. On the System DSN tab, click Add.
4. Select the SQL Server driver from the list. Click Next.
5. Specify the name of the ODBC Connection.
6. Enter a description of the data source.
7. Select the SQL Server from the Server drop-down list. Click Next.
8. Specify the authentication mode (Integrated Windows security / SQL Server authentication) and the login credentials, if applicable. Click Next.
9. Change the default database to iBoxTermStore. Click Next.
10. Click Finish to end the ODBC SQL Server setup.
11. In the next window, click Test Data Source to ensure that you can connect to the
data source.
12. Click OK to save the settings.
How to create synchronized category
1. Create a new category in WorkZone Find ModelBuilder which will be the destination
for imported SharePoint Managed Metadata.
2. In the Category Details dialog box, click the Synchronization tab.
3. Select the Enable synchronization and Synchronize Relations check boxes:
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Note: If the “.parent” relation is not visible, click Tools > Local iBox Settings, then click
the Advanced tab and set the ShowAdvancedTab value to True.
How to configure WorkZone Find ODBC Connector
1. Open WorkZone Find AD ODBC Manager.
2. On the ODBC Connector tab, click Edit.
3. In the ODBC Connector Settings dialog box, select the required category and
click Edit. The ODBC Properties dialog box is displayed.
4. On the General tab, in the Data Source Name section, select the ODBC DNS
which you created during the ODBC DataSource Configuration.
5. Click Connect.
6. From the Table name drop-down list, select:
TableName=> [dbo].[iBoxTermStore],
ID column => [ID],
Display Name Column => [Name],
Synonym columns => [Synonyms].
7. Click Select Columns. The Select one column dialog box is displayed. Select
the column which contains the parentID and click OK.
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8. Select the RAW FingerPrint check box to bind the .parent relation to the [ParentId] table column.
9. Click OK.
10. Start ODBC Connector.
11. When the scan completes successfully, the terms will be added in WorkZone Find
ModelBuilder.
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Populating the terms automatically using Auto Term Rule Editor
You can add the metadata terms automatically to the information model based on information
blocks, for example, folders, files, SharePoint lists and so on; and their associated properties
using the Auto Term Rule Editor.
Auto Term Rule Editor is designed to populate model terms based on the information blocks.
For example, if you are maintaining individual folders (in NTFS or SharePoint) for every project
with the folder name matching the project name, an WorkZone Find ModelBuilder category
called Projects can be created and populated with terms containing the names of the projects by
choosing the folder as the source information block in the Auto Term Rule Editor.
To work with the Auto Term Rule feature, make sure that the WorkZone Find AutoTerm service
is running on WorkZone Find server.
Example of use
The example below explains the use of Auto Term Rule Editor to populate metadata terms
based on folder information blocks.
For instance, all the project documents are stored in SharePoint in relevant project folders:

In this example, the folder “Prevent Aids” contains a set of subfolders and we want to create
model terms for the subfolders as well.

The procedure below explains how to use the AutoTerm Rule feature to populate metadata
terms from both top level folders and sub level folders.
How to populate metadata terms
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1. Right-click a category and select Edit AutoTerm Rule.
2. On the Information Block Types tab of the AutoTerm Rule Editor dialog box,
select the Folder check box in the SharePoint section (the purpose is to create
terms matching the terms on the SharePoint folders).

3. Click the Scan scope tab. Select the Scan chain of related blocks option button.
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4. Click Edit next to the Scan Root field.

5. In the Scan Root field, specify the Unique ID (UID of the parent block, in this
example, “Projects and Materials”).
How to find UID
1. Open WorkZone Find Index Manager.
2. Click the iBlocks tab. In this example, the folder “Projects and Materials” is
the parent folder and it is located on the SharePoint site called “Build 90”.
3. From the Filter by drop-down list, select Location.
4. From the iBlock loc drop-down list, select the relevant location. In this example, the exact location of the “Projects and materials” folder is
http://lbmossb/build90.
5. Click Go. All the iBlocks - including the “Projects and Materials” folder - in the
specified location are displayed in a list.
6. Double-click the name of the parent folder iBlock – “Projects and Materials”. A
window containing detailed information of the parent folder is displayed.
7. In the UID field, UID of the specific folder is available. Double-click UID and
copy it.

6. Paste UID into the Scan Root field. Click OK.
7. Leave the default value selected in the Scan Relation drop-down list. Current
version of WorkZone Find supports only the .containingfolder relation.
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8. From the Scan Depth list, select the number of levels of subfolders to be included
when terms are auto created.
9. In this example, there are four levels of subfolders. Therefore the number 4 is
selected. If you want to create a term for the parent folder, select the Include
Scan Root check box (create an Auto Term for the scan root).
10. Click the Auto Term options tab.
11. Select the Create Auto Terms check box. The Name source drop-down list is enabled.
Select Name (DataType: String (as the goal is to create terms based on the Name
property of SharePoint folders).
Other properties for automatically populating the information model terms are available in the drop-down list.
l

Cutting characters - it is possible to use only a part of a property. To do
this, specify a character, for example, a punctuation mark in the Cutting
characters field.
If, for instance, folder names contain commas to separate words or strings
of words, use comma as a cutting character. In this case only the first part,
for example, “Water Conservation”, of the folder name “Water Conservation, Waste Water Treatment” is used to create auto terms.
Only the part of the property located before the split character is extracted
for term creation. The rest of the property will be ignored.

l

More than one split character – you can specify more than one split character, for example “,”, “.”, and “:”.
When used to create grouping terms, split characters work differently –
this is explained in the following sections.

12. Click Auto Term Options.
How to create the term creation options
l

Tag source - The source, for example, the folder, needs to be tagged with the new
term when the term is created. In our example, the Auto Term Rule will create a term
called ‘Project Greenhands’ in the information model since we have a folder with that
name. If you select the Tag Source check box, the folder ‘Project Greenhands’ will
automatically be tagged with the term ‘Project Greenhands’ when the term is created.

l

Make Term Taggable - Any term in the information model can be marked as taggable or non-taggable. A term marked as taggable means that it is available for tagging. Generally, grouping terms that should not be used for tagging should be marked
as non-taggable. Refer to section Tagging options to learn more.

l

Make Term Suggestable - If the feature “Suggest term” is enabled, the term will be
suggested to the user when the user tags a document which contains content related
to the term. Refer to section Tagging options to learn more.

l

Auto Tagging - WorkZone Find automatically tags documents with matching terms
only if the terms are marked for auto tagging. If a term is not marked for auto
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tagging, a document containing the term will not be automatically tagged even if
the category is used in an auto tagging rule. If you want the automatically created
terms to be used for auto tagging, select this option. Refer to section Tagging
options and section Working with automatic tagging to learn more.
l

Use term as Fingerprint - By default the value of the Fingerprint property is generated on basis of the iBlock ID. For example, Fingerprint=$.7ec37bf2-12f046c7-8ade-773a67a74a7b, where 7ec37bf2-12f0-46c7-8ade-773a67a74a7b is
iBlock ID. Select this checkbox if you want to use the name of the term as a basis
for the Fingerprint property.

How to configure the term update options
l

Update Name - Select this check box if the name of the new terms needs to be
updated when the source name changes. In this example, terms are created based
on the SharePoint folder structure. If one of the folders is renamed, the corresponding term created in WorkZone Find ModelBuilder will be renamed if this
option is chosen.

l

Update Security - Select this check box if the new term security needs to be in
sync with a change in source security.

l

Update Hierarchy - Select this check box if the hierarchy of new terms needs to
be updated with the change in the source hierarchy. For example, if you included
subfolders to create auto terms, and if one of the subfolders is moved to another
folder, then the corresponding term will also move to the new hierarchy.

l

Delete if Source Deleted - Select this option if you want the terms to be deleted
from the information model if the source is deleted. In our example, if one of the
folders is deleted, the associated term will also be deleted from the information
model.

l

Delete if Source Soft Deleted - Select this check box if you want the terms to
be deleted from the information model if the source is soft deleted.

HOW TO CONFIGURE THE SECURITY OPTIONS
l

Same as Source - Select this option button if the security of the new terms should
be the same as the source security. In the example, if the security settings of one of
the folders are such that only “Jane Doe” can view and modify it, the corresponding
term created in the information model will have the same security (that is, only
“Jane Doe” can view and modify the term).

l

Same as Category - Select this option button if the new terms need to inherit the
security specified in WorkZone Find ModelBuilder category regardless of the source
security.

l

Allow Everyone Access - If this option button is selected, all users will have
access to new terms regardless of the security specified in the source block or in the
information model category in which the terms are created.

How to configure the term hierarchy options
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l

None - If this option is selected, the new terms are created as stand-alone terms without belonging to any hierarchy.

l

Mimic Source Relation - If this option is selected, term hierarchy is created with ‘Containing Folder’ relation. In other case there will be no hierarchy.

l

Use Grouping Term - If this option is selected, the duplications in terms will be
avoided.

Using Grouping Term Options
You can populate the terms automatically by using the settings on the Grouping Term options
tab of the AutoTerm Rule Editor dialog box.
The difference between creating terms through Auto Term options and Grouping Term options is
described below.
When you use Auto Term options, a new term is created for every information block type in the
scan scope (1:1).
When you use Grouping Term options, Auto Term Rule checks for duplicates before a new term is
added to the model. Therefore, the terms created using the grouping term options, do not contain
duplicates.
For example, you have files with different extensions stored in a SharePoint document library. You
can automatically create terms based on these file extensions using grouping term options, and
then automatically tag the files with these terms by means of a property query. To do this, you
need to create extensions as tags in an “Extensions” category.
How to create extensions as tags
1. Create a category called “Extension” in WorkZone Find ModelBuilder. Check out the
new category.
2. Right-click the category and select Auto Term Rule Editor.
3. On the Information Block Types tab, select the File check box, because the
extension property is associated with files.
4. On the Scan scope tab, select the location which contains files with different extensions.
5. Click the Grouping Term options tab (to avoid creating a term for every file, you
should not use the Auto Term options tab). Select the Create Grouping Terms
check box.
6. From the Group name source drop-down list, select Extension.
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7. Term creation options, Term update options, and Security options should be configured the same way as described in section 2.17 Automatic Term Population
Using Auto Term Rule Editor.
Note: There is no “same as source” option in the security options because source security
cannot be inherited by a grouping term.
If the property selected in Group name source is stored as an array, then if you select the
Treat multiple group names as hierarchy check box, a hierarchy of terms will be
created.
For example, if there is a “multiple lines of text” property in SharePoint and if you use it in
Group name source list to create grouping terms, a term hierarchy will be created in the
information model where the first line is the parent term and the second line is its child term,
and so on.
8. Select the Clean-up Category check box in the following situations:
l

if you make changes to an Auto Term Rule for which terms are already
populated;

l

if you want to delete the old terms and clear the category before populating new terms.

9. Select the Rule enabled check box to enable the rule.
10. Click OK to save the settings.
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11. Save the information model and restart WorkZone Find ModelBuilder again. Now
you can see that the “Extension” category has been populated with different file
extensions:

Using auto term options and grouping term options together
Wrong use of these settings can clutter WorkZone Find ModelBuilder and this will result in poor
performance.
You can use the Auto Term options and Grouping term options functionalities together while
creating an Auto Term Rule. The terms populated using the Grouping Term options functionality will
be the parent terms. The terms populated using the Auto Term options functionality will be the child
terms based on the relation with the parent term.
This is applicable only when you select the Use Grouping Term option button in the Term
hierarchy options section on the Auto Term options tab.
The terms populated with Auto Term options functionality could contain duplicates (if there are
duplicates in the source blocks), because new terms are created for every source block regardless
of the fact that they already exist in the model.
The terms populated by Group Term options functionality do not contain duplicates. The Auto Term
Rule checks for duplicates before adding a new term to the category.
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Advanced WorkZone Find settings
Further customization of WorkZone Find ModelBuilder can be performed from the WorkZone
Find Settings Editor.
Note: These parameters are normally set during the WorkZone Find installation process.
ScanJour recommends that you leave the default values. If you make changes, close and
reopen WorkZone Find ModelBuilder for changes to take effect.
How to acces the advanced WorkZone Find settings
To access the advanced WorkZone Find settings, perform the following steps.
Note: If you want to edit the settings for all users, you must be logged on as administrator.
1. Open WorkZone Find ModelBuilder.
2. Select Tools > Local iBox Settings.
3. In the WorkZone Find Settings Editor dialog box, configure the settings as
required. Click an item to see further information in the help text at the bottom of
the window.
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Managing security and user rights
The users can have reading, writing, and editing rights which are determined by Active Directory.
The tag that a user can apply or even see is handled in the Rights settings in WorkZone Find
ModelBuilder. You can set user rights for each category and term in the information model. The
process of setting up WorkZone Find Model Security is similar to setting access rights on files and
folders using Windows Explorer.
Before changing security settings in WorkZone Find ModelBuilder, it is necessary to run AD
Connector. Once you have changed the security settings and saved the changes, run AD Connector
again to activate the changes.
File Security should not be based on “Authenticated Users” but only on more static groups and
users in order for WorkZone Find to respect file security settings.
USER RIGHTS

There are four types of user rights in the information model:
l

View

l

Tag

l

Modify

l

Owner

The View and Tag rights affect only the search and tagging interfaces. The Modify and Owner
rights affect only WorkZone Find ModelBuilder.
The View rights determine whether terms and tags are visible for the user in the Search and
Tagging interfaces.
The Tag rights determine whether the user is allowed to tag with a specific term.
l

If you deny the Tag rights on a term level, the terms are still visible and not allowed for
tagging. If the Suggest Term functionality is enabled, it will still be shown under “Suggest Term”, but it will be not possible to tag with.

l

The Tag rights are dependent on View rights.

l

If you deny the View rights, then the Tag rights will also be denied.

The Modify rights determine if a user can check out and edit a model category or a term in
WorkZone Find ModelBuilder.
The Owner rights determine if a user can change the security settings for a given category or
term in WorkZone Find ModelBuilder.
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SECURITY RIGHTS

A security right can have three values: Empty, Allow, or Deny.
l

Empty displayed as a cleared check box. It means that the right has not been granted.
In the figure above, the user “Guest” has not been granted the Tag rights.

l

Allow displayed as

. It means that the right is inherited whereas a green checkmark

means that it is explicit.
l

Deny displayed as

. It means that the right is inherited, whereas

means that it is

explicit. Deny means that the user does not have the right.
SECURITY RIGHTS PRECEDENCE

The denied or granted rights for an individual user overrule the rights denied or granted for the
groups which the individual user is a member of.
The Allow rights take precedence over the Empty rights.
The Deny rights take precedence over the Allow rights.
Example
The user “Guest” is a member of the “NOVIEW” group and this group does not have the View
rights (empty). In this case, even though all members of the group do not have the View
rights, “Guest” will have view rights, because the Allow rights defined for the user will take
precedence over the Empty rights defined for the group.
ENABLING SECURITY

All the categories have the Enable Security check box. This can be used to enable or disable
security for a category and all its child terms.
Disabling security on the root category will disable security on all child categories. Enabling
security on a child category will require enabling security on the root category.
Note: The permission sets are not lost when you disable security. They will be available and
take effect again when you enable the security.
How to enable security
1. Check in as a model administrator - see section Saving changes to the Information Model.
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2. Check out a category.
3. Right-click the category and select Details.

4. In the Category Details dialog box, select the Enable security check box.
5. Click Close. Now that security is enabled, the rights can be edited for groups or
users (Empty, Allow, or Deny).
From the Show drop-down list, you can choose which rights should be displayed:
All rights, User interface rights, or Administrative rights.
On the Rights tab of a category there are three buttons:
l

Clear - click this button to clear the non-inherited permission entries for the selected
item and its child items.

l

Add - click this button to add a new user or group.

l

Delete - click this button to delete the selected user or group.
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Working with automatic tagging
The automatic tagging in WorkZone Find is set up using Automatic Tagging Configuration
component. It is accessible in the WorkZone Find Index Manager.
How to enable automatic tagging
1. Open WorkZone Find Index Manager.
2. Click File > Index Settings (<Servername>) ....
3. The IndexSettingsC section is displayed.
4. In the sub section Auto Tagging, set the AutoTagManuallyTagged value to
True.
5. Go to another field after changing the field using the tabulator or by clicking, and
click the Apply button to confirm the change.
6. You can now close Index Manager.

How to access the Automated Tagging Configuration
1. Open WorkZone Find Index Manager.
2. Click File > Automated Tagging Configuration.
3. The Automated Tagging Configuration dialog box is displayed. In this dialog
box you can assign queries to locations. It contains two lists:
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A list of auto tagging queries.

l

A list of scanable locations.
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4. Automatic tagging in WorkZone Find is divided into two types:
l

Automatic Property Tagging

l

Automatic Free text Tagging

Automatic tagging is triggered by the index at regular intervals which can be
configured.
In WorkZone Find auto tagging rules are not inherited correctly if rules are already
applied at lower level locations. ScanJour recommends placing all the auto tagging
rules on the same level.
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Automatic property tagging in NTFS
Automatic property tagging can be used to automatically tag information items based on the
following:
l

NTFS properties

l

MS Office properties

Below is an example of how automatic property tagging works. In this example folders with
different names are related to the company names in the NTFS share. The aim is to
automatically tag these folders based on their names using a property query. To do this, you
need to create company names as terms in the “Company” category.
1. In WorkZone Find ModelBuilder create a category called “Company” that contains
the names of companies. You can use ODBC Connector to automatically populate
such a category with company names. For more information, refer to the Configuration Guide.
2. Enable the terms for auto tagging.
How to enable the terms for auto tagging
1. Double-click the category.
2. In the Category Details dialog box, click Child Tagging Options.
3. In the Auto Tagging section, select the Enable on all terms check box.
4. Click OK.

3. Open WorkZone Find Index Manager. Click File > Automated Tagging Configuration.
4. In the Automated tagging configuration dialog box, right-click Auto tagging
queries and select New query.
5. In the Name field, type a name for the query, for example, “P_Company_FolderName”, where:
P - means that it is a property query,
Company - defines the category used in the query,
Folder - represents the Block Type,
Name - specifies that the property query is based on the iBlock Name.
6. In the Type field drop-down list, select Property.
7. On the General tab, select Exact from the Text matching drop-down list.
Note: You can also select the Prefix for property and free text queries in all the repositories
supported by WorkZone Find (NTFS, SharePoint, and Captia) from the drop-down list. For the
prefix matching to work, the exact term name in full should be present as the beginning part of
the property.
8. Click the iBlock types tab. Select the type of information items to auto tag using
this query, in this example, “Folder”.
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9. Click the iBlock property types tab. Select the Name item, because auto tagging
will be based on the name of the folder.
Note: The automatic property tagging will work only if there are terms in the information model
matching the name selected in the auto tagging query, and if these terms are enabled for auto
tagging.
10. Click the Categories tab. Select the category that contains terms matching the item
property (folder name), in this example, “Company”.
11. Click the Category property types tab. Select “Name”, because the matching on
which it is based is the name of the company.
12. Click OK to save the query. The added query is displayed under Auto tagging queries section of the tree.
13. Associate the query with the required location.
How to associate the query
1. Select the location in the left pane of the Automated tagging configuration window. All the available queries will be displayed in the right pane.
button to associate the query with the location. In
2. Select a query and click the
this example, folders in the NTFS share are called “iboxshare” on the server
“server”. You need to link that scan location with the auto tagging query.

14. Click OK to save the configuration.
Note: The location must be included into the connector scan scope before it can be used for
automatic tagging.
15. To run auto tagging, in WorkZone Find Index Manager click Tools > Auto tag.
16. Click the Log tab. The log shows that the auto tagging has started and a number of
auto tags have been added.

17. After the auto tagging process has run successfully, find the required items in the
search results and verify that the folder is tagged with the appropriate terms. In this
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example, it should be tagged with the company name “Intel” as shown below: 10
folders in the share were used for auto tagging. The index log also showed that 10
tags were added automatically, so that all the files and folders in the share were
automatically tagged with companies.
How to manage automatic property tagging based on file system and MS Office properties
WorkZone Find supports automatic property tagging based on file system properties. The
properties like Author, Title, Name, URN, URL, Size, FileExtension, Owner, and so on, can be
used for auto tagging purpose provided that there are matching terms in the information
model and that the terms are enabled for auto tagging.
WorkZone Find can use NTFS, Captia, SharePoint or MS Office properties supported by
WorkZone Find for auto tagging purposes. The lists of supported properties are displayed in
the Automated Tagging Configuration dialog box on the b tab (in the Index Manager, click
File > Automated Tagging Configuration).
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Automatic property tagging in SharePoint
You can convert SharePoint metadata stored in SharePoint Columns into WorkZone Find Metadata
and subsequently use it to automatically tag information items in SharePoint. It is only possible to
convert SharePoint Columns which have the following SharePoint Properties: “Single Line of Text”,
“Multiple Line of Text”, “Choice Fields”, “Date & Time” , “Currency”, “Hyperlink”, “Look up”,
”Person/group”.
Example: The SharePoint Document Library has a SharePoint Column named “Doc Responsible”.
The documents have applied values – see the SharePoint property value applied to documents in
the “Doc Responsible” column:

The process is as follows: Extract the metadata stored in SharePoint, convert it to WorkZone Find
metadata using AutoTerm Rule Editor feature, and subsequently use the property values to
automatically tag the appropriate documents in SharePoint.
How to perform automatic free text tagging
1. Create a category called “Author” in WorkZone Find ModelBuilder and automatically
populate the category with the SharePoint property “Doc Responsible”. You can
either create terms manually in WorkZone Find ModelBuilder or use the auto term
rule feature in WorkZone Find ModelBuilder to automatically populate the category
with the SharePoint property values.
2. When the category has been populated, ensure that the terms inside are enabled for
auto tagging.
3. Open WorkZone Find Index Manager. Click File > Automated Tagging Configuration.
4. In the Auto Tagging Configuration dialog box, create a property query – see section Automatic property tagging in NTFS.
5. Select the property on the iBlock Property Type tab. In this example, the SharePoint property is called “Doc Responsible”. Therefore, select the iBlock property
type named “Doc Responsible”.
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6. Once the query is created, save it and link the query to the location as explained
in section Automatic free text tagging. In this example, the location is “Doclib1”
document library as shown below:

7. Click OK to save the configuration.
8. In WorkZone Find Index Manager, click Tools > Auto tag to start the automatic
configuration.
9. In the SharePoint Document Library, right-click the different documents to open
Tagging Client and verify that they have been tagged with an appropriate “Document Responsible” tag.
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Automatic free text tagging
WorkZone Find allows automatic tagging of files based on their free text (content).
The preconditions for automatic free text tagging are as follows:
l

The file must contain the metadata term that you want to tag with.

l

Auto tagging must be enabled for the term in WorkZone Find ModelBuilder.

How to configure WorkZone Find for automatic free text tagging
1. Open WorkZone Find Index Manager.
2. Click File > Automated Tagging.
3. In the Automated tagging configuration dialog box, right-click the Auto tagging queries item in the tree and select New query.
4. Type a name in the Name field. From the Type drop-down list, select Automated
tagging configuration. Select the Use advanced freetext options check box.
From the Text matching drop-down list, select Exact.
Note: When naming queries, it is important to follow a uniform naming convention which makes
it easier to identify and maintain auto tagging queries.
5. On the iBlock types tab, select File.
6. On the Categories tab, select one or more categories that contain terms used for
automatically tagging files based on their free text contents. In this example, “Subject”.
7. On the Category property types tab, select Name. Click OK to save the query.
8. Link the location of the documents to be automatically tagged with the “Subject”
with the free text query created.
How to link the document location with a free text query
1. Expand the Location node of the tree.
2. Select the connector and the scan location.
3. Select the queries that you want to apply to the selected location.
4. Click OK.

9. Click OK to save the configuration. In the example below, the query “F_Subject” (F
stands for free text, and Subject is the category used in the query) has been applied
to the highlighted location to the left.
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Advanced automatic tagging
You can automatically tag an information item with a metadata term matching a specific
property of the document.
Example
There is a category called “Author” in WorkZone Find ModelBuilder which contains names of
all the employees in the organization as its terms. You want to automatically tag a document
if the author property of the document matches any of the terms in the “Author” category.
Note: “Author” is a Microsoft Office document property and it is only applicable to Microsoft
Office files (Word, Excel, PowerPoint, and so on).
In the example below, the Microsoft Word document “Test1.docx” has a value called “Jane
Doe” in its author property:
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There is a term called “Jane Doe” in the “Author” category in WorkZone Find ModelBuilder. The
challenge here is that only the ”Author” property of this document and the terms in the “Author”
category should match.
How to configure advanced auto tagging
1. Open the automated tagging configuration window – see section Working with automatic tagging.
2. In the Automated tagging configuration window, right-click Auto tagging queries.
3. Create a new free text query and assign a relevant name – see section Automatic
free text tagging.
4. On the General tab, select the Use advanced freetext options check box. The
Fields tab will be displayed.
5. Click the iBlock types tab and select File to tag the documents automatically.
6. Click the Categories tab and select one or more categories that contain the names
of authors. In this example, the category is “Author”.
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7. Click the Category property types tab and select “Name”.
8. Click the Fields tab and select “Author”. You need to do this because matching
should be based on the “author” property of the document.
Note: Other Lucene fields can also be used. The list of fields that can be used for auto tagging
can be configured under LuceneTextIndexSettings.
More information on Lucene
Contact WorkZone Find support for further information on how to configure it.

9. You can specify the search mask to include additional conditions while doing the
matching. For example, use wild card characters such as “*” (asterisk) to perform prefix matching. In this example, if you specify “*” in the search mask after
the search criteria, the auto tagging engine will perform a prefix matching rather
than an exact matching. So, if a metadata term in the author category in WorkZone Find ModelBuilder is called “Jane”, and if a document contains the value
“Jane Doe” in its author property, the document will be automatically tagged with
the term “Jane” even though there is no exact match.
It is possible to specify all the supported Lucene operators and fields in the
search mask field.
Note: When specifying additional operators and fields, remove the quotation marks
enclosing the search criteria in the search mask.
10. Click OK to save the query.
11. In WorkZone Find Index Manager, click Tools > Auto tag to run the auto tagging.
12. Wait until the auto tagging process has run successfully. The documents have
now been tagged. In this example, the document “John Doe.docx” has been automatically tagged with the term “Jane Doe”.
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Advanced Automatic Tagging Search Mask
The search mask defined in the Fields tab enables the auto tagging administrator to create
custom rules.
To use the search mask feature, you must understand how the auto tagging process works in
WorkZone Find. The feature is based on Lucene technology.
When auto tagging is executed, WorkZone Find traverses all categories and builds a query for each
term. All the iBlocks that match the query will be tagged with the term.
This query is built using the search mask you define (or the default mask if you have changed
nothing). The default search mask for the automatic tagging is defined as:
${fieldname}:”${searchcriteria}”
Example
In the example from section 3.3.1 Advanced Automatic Tagging, this means that when the auto
tagging encounters the term “Jane Doe”, the following query is built:
author:”Jane Doe”
As you can see, ${fieldname} is substituted with the actual field name, and ${searchcriteria} is
substituted with the contents of the term.
If more than one field is selected, the query is constructed as an OR-query like this:
(fieldname1:${searchcriteria}) OR
(fieldname2:${searchcriteria}) OR …
If the query from the example was extended with a field named “creator”, the query would look
like this:
author: “Jane Doe”) OR (creator: “Jane Doe”)
How to find not exact matches
Understanding this substitution (see Example) and knowing the syntax of the Lucene free text
search opens a lot of opportunities.
If, for example, the “Jane Doe” was actually called “Jane Mary Doe”, and in some of the
documents her middle name was used, then the auto tagging would only tag the documents
which had an author with the exact name “Jane Joe”.
There are two possible solutions to this problem.
One solution to this problem is to add aliases to the “Jane Doe” term which contain all variants of
her name (as synonyms in WorkZone Find ModelBuilder), but someone would have to maintain
these aliases.
An easier (but not as exact) solution is to change the search mask to accept all authors who have
the names “Jane” and “Doe” within a certain distance of each other.
When you do a phrase free text search in WorkZone Find, you can use the operator ~ followed
by a number to indicate that you want to find all documents which contain all the words in the
phrase within some distance of each other.
If you do the search with a distance 1, then type:
“Jane Doe”~1
As a result you will find documents containing “Jane [some word] Doe” and documents
containing “Doe Jane”.
The distance is the number of word moves which should be done to put the words in the right
place.
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You will not find “Jane [some word] [some other word] Doe” when you search with a distance
of 1.
The phrase distance search can be used in the query by changing the search mask:
${fieldname}:”${searchcriteria}”~2
This mask will generate the following query:
author:” Jane Doe”~2
You can use all the search operators available in Lucene when you declare auto tagging
search masks.
Note, that some search operators are word operators and some are phrase operators.
When you use the word operators, you have to remove the quotes from the search mask. For
example, if you want to use the truncation operator ‘*’, the search mask would look like this:
${fieldname}:${searchcriteria}*
But if the term contains a phrase, for example, more than one word (like “Jane Doe”), this
would expand the search criteria:
author:Jane Doe*
This search finds all documents containing the word “Jane” in the author field or words
starting with “Doe” in the free text. This is, however, not recommended.
To avoid this, you should only use the word operators (and remove the quotes from the
mask) when you are certain that the terms used in the query do not contain more than one
word.

Disabling automatic tagging
In some situations you may want automatic tagging to be executed on a parent level, but with
some of the child levels left unaffected by the automatic tagging.
You can disable automatic tagging for specific locations by assigning an empty query to them.
How to disable automatic tagging
1. In the Automated tagging configuration dialog box, right-click Auto tagging
queries and select New query. In the Name field, specify a name for the
empty query.
2. From the Type drop-down list, select Empty.
3. Click OK to save the query.
4. Select the location to be disabled for automatic tagging. Link the empty query to
the location.
5. Click OK to save configuration. Documents in the location linked to an empty
query are not automatically tagged.
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Scheduling Automatic Tagging
ScanJour recommends that you set automatic scanning and auto tagging to regular intervals. This
is done using WorkZone Find Index Manager.
You can also force auto tagging if you want new auto tagging rules to be applied immediately,
without waiting for the next scheduled scan.
How to set scan intervals
1. Open WorkZone Find Index Manager.
2. Click File > Index settings.
3. In the IndexSettingsC dialog box, change the Auto TaggingInterval value (in
hours).
How to perform force auto tagging
1. Open WorkZone Find Index Manager.
2. Click Tools > Auto tag to run auto tagging.
3. Wait for the auto tagging process to run successfully.
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